Project

General

Profile

Actions

Misc #18747

closed

DevMeeting-2022-05-19

Added by mame (Yusuke Endoh) 8 months ago. Updated 7 months ago.

Status:
Closed
Priority:
Normal
Assignee:
-
[ruby-core:108358]

Description

The next dev meeting

Date: 2022/05/19 13:00-17:00 (JST)
Log: https://github.com/ruby/dev-meeting-log/blob/master/DevMeeting-2022-05-19.md

  • Dev meeting IS NOT a decision-making place. All decisions should be done at the bug tracker.
  • Dev meeting is a place we can ask Matz, nobu, nurse and other developers directly.
  • Matz is a very busy person. Take this opportunity to ask him. If you can not attend, other attendees can ask instead of you (if attendees can understand your issue).
  • We will write a record of the discussion in the file or to each ticket in English.
  • All activities are best-effort (keep in mind that most of us are volunteer developers).
  • The date, time and place of the meeting are scheduled according to when/where we can reserve Matz's time.
  • DO NOT discuss then on this ticket, please.

Call for agenda items

If you have a ticket that you want matz and committers to discuss, please post it into this ticket in the following format:

* [Ticket ref] Ticket title (your name)
  * Comment (A summary of the ticket, why you put this ticket here, what point should be discussed, etc.)

Example:

* [Feature #14609] `Kernel#p` without args shows the receiver (ko1)
  * I feel this feature is very useful and some people say :+1: so let discuss this feature.
  • It is recommended to add a comment by 2022/05/16. We hold a preparatory meeting to create an agenda a few days before the dev-meeting.
  • The format is strict. We'll use this script to automatically create an markdown-style agenda. We may ignore a comment that does not follow the format.
  • Your comment is mandatory. We cannot read all discussion of the ticket in a limited time. We appreciate it if you could write a short summary and update from a previous discussion.

Related issues 1 (1 open0 closed)

Related to Ruby master - Misc #14770: [META] DevelopersMeetingOpenActions
Actions #1

Updated by mame (Yusuke Endoh) 8 months ago

  • Related to Misc #14770: [META] DevelopersMeeting added

Updated by Eregon (Benoit Daloze) 8 months ago

  • [Bug #18751] Regression on master for Method#== when comparing public with private method (eregon)
    • How do we fix? Restore 3.0-3.1 behavior for #==, or introduce new method to compare if 2 Method/UnboundMethod have the same definition (regardless of visibility)?

Updated by byroot (Jean Boussier) 7 months ago

  • [Feature #18595] Alias String#-@ as String#dedup
    • Unary operator have some precedence oddities, forcing to use parantheses.
    • dedup is quite an explicit name.

Updated by tenderlovemaking (Aaron Patterson) 7 months ago

  • [Feature #18611] Promote best practice for combining multiple values into a hash code
    • Encourage people that implement hash to use Array#hash for implementation
    • We can easily optimize [x, y, z].hash to eliminate array allocations
    • Users get faster, easier, and correct implementation of their own hash methods

Updated by tenderlovemaking (Aaron Patterson) 7 months ago

tenderlovemaking (Aaron Patterson) wrote in #note-4:

  • [Feature #18611] Promote best practice for combining multiple values into a hash code
    • Encourage people that implement hash to use Array#hash for implementation
    • We can easily optimize [x, y, z].hash to eliminate array allocations
    • Users get faster, easier, and correct implementation of their own hash methods

Looks like [Feature #18611] was merged, so please remove it from the agenda. Thanks!

Updated by byroot (Jean Boussier) 7 months ago

Actions #7

Updated by alanwu (Alan Wu) 7 months ago

  • [Bug #18730] Double return event handling with different tracepoints
    • In one situation, enabling a TracePoint inside another runs the second hook within the same event https://bugs.ruby-lang.org/issues/18730#note-6
    • Is it reasonable to not call the newly added hook inside the same event for consistency?

Updated by byroot (Jean Boussier) 7 months ago

  • [Feature #14602] Version of dig that raises error if a key is not present
    • Proposed names: in the issue deep_fetch, dig!, dig(..., exception: true)
    • My preference would go to deep_fetch, but maybe we can find better?
    • Sometimes dig is used because it's shorter and more convenient than .fetch(:a).fetch(:b), but an early error would have been preferable.

Updated by Eregon (Benoit Daloze) 7 months ago

  • [Feature #18774] Add Queue#pop(timeout:) (eregon)
    • OK?
    • Anyone wants to implement it for CRuby?

Updated by Dan0042 (Daniel DeLorme) 7 months ago

  • [Feature #18742] Introduce a way to tell if a method invokes the super keyword or not
    • It's currently possible to do this with RubyVM::InstructionSequence, but non-portable and a bit slow.
    • I think it would be useful and cheap to keep this metadata in [Unbound]Method.

Updated by jeremyevans0 (Jeremy Evans) 7 months ago

  • [Bug #18407] Behavior difference between integer and string flags to File creation (jeremyevans0)
    • I don't think it's worth breaking backwards compatibility to allow File::BINARY to work on Unix.
    • Do we want to reject this, or make it so that File::BINARY has the same effect as the 'b' option?
  • [Bug #18740] Use of rightward assignment changes line number needed for line-targeted TracePoint (jeremyevans0)
    • Using rightward assignment can change the line numbers needed for TracePoint.
    • Is this a bug, or do we consider it an implementation detail?
  • [Bug #18727] Make failed on x86_64-cygwin (LoadError) (jeremyevans0)
    • Considering all modern Windows systems can support WSL (Windows Subsystem for Linux), do we want to continue to support Cygwin?
    • We have 17 open bugs related to Cygwin support.
    • Cygwin platform has no maintainer.
    • We could probably remove a significant amount of code by dropping Cygwin support.
    • I recommend that we drop Cygwin support unless someone wants to step up as maintainer and start fixing Cygwin bugs.
  • [Bug #18294] error when parsing regexp comment (jeremyevans0)
    • I was able to develop a fix for this, but I'm not sure whether the fix is acceptable.
    • The problem is actually wider than just extended regexps, it can affect any regexp if the (?# comment syntax is used.
Actions #12

Updated by mame (Yusuke Endoh) 7 months ago

  • Description updated (diff)
  • Status changed from Open to Closed
Actions

Also available in: Atom PDF

Like0
Like0Like0Like0Like0Like0Like0Like0Like0Like0Like0Like0Like0