Project

General

Profile

Feature #7226

Add Set#join method as a shortcut for to_a.join

Added by nathan.f77 (Nathan Broadbent) almost 8 years ago. Updated over 6 years ago.

Status:
Rejected
Priority:
Normal
Target version:
[ruby-core:48498]

Description

I was surprised that Set.new.join gives me a NoMethodError.
This patch that adds a #join method to Set, which is a shortcut for to_a.join.


Files

add_join_to_set.patch (788 Bytes) add_join_to_set.patch nathan.f77 (Nathan Broadbent), 10/28/2012 05:38 AM
add_join_to_set.patch (756 Bytes) add_join_to_set.patch nathan.f77 (Nathan Broadbent), 10/28/2012 05:45 AM

Related issues

Related to Ruby master - Bug #1893: Recursive Enumerable#join is surprisingClosedmatz (Yukihiro Matsumoto)08/06/2009Actions
Is duplicate of Ruby master - Feature #5970: Add Enumerable#join with same semantics as Array#joinAssignedmatz (Yukihiro Matsumoto)Actions

Also available in: Atom PDF