Project

General

Profile

Actions

Feature #2982

closed

Ruby tries to link with both openssl and readline

Added by lucas (Lucas Nussbaum) over 12 years ago. Updated over 11 years ago.

Status:
Third Party's Issue
Priority:
Normal
Assignee:
-
Target version:
-
[ruby-core:28735]

Description

=begin
Hi,

Ruby currently tries to link with both OpenSSL (which is under the SSL license), and Readline (GPL).
This is not allowed. For more information, see for example http://people.gnome.org/~markmc/openssl-and-the-gpl.html and http://www.mail-archive.com/debian-legal@lists.debian.org/msg38757.html .

I have heard of a legal decision that makes this OK for scripting languages if the two libraries aren't loaded by default in the same address space.

A possible solution could be to port Ruby to use the GNU TLS library.
=end


Related issues 2 (0 open2 closed)

Has duplicate Ruby master - Feature #2032: Change the license to "GPLv2+ or Ruby's original".Closedmatz (Yukihiro Matsumoto)09/02/2009Actions
Has duplicate Ruby master - Feature #2983: Ruby (GPLv2 only) tries to link to with readline (now GPLv3)Third Party's Issue03/18/2010Actions
Actions

Also available in: Atom PDF