Project

General

Profile

Actions

Feature #2983

closed

Ruby (GPLv2 only) tries to link to with readline (now GPLv3)

Added by lucas (Lucas Nussbaum) over 12 years ago. Updated over 11 years ago.

Status:
Third Party's Issue
Priority:
Normal
Assignee:
-
Target version:
-
[ruby-core:28736]

Description

=begin
Hi,

The readline library was relicensed under GPLv3. Since Ruby is GPLv2 only, it is not allowed to link to readline.

Most distributions currently ship both the (old) GPLv2 readline version, and the new GPLv3 readline. However, this is likely to change in the future.

A solution could be to use a different library, like libedit (http://www.thrysoee.dk/editline/)
=end


Related issues 2 (0 open2 closed)

Is duplicate of Ruby master - Feature #2032: Change the license to "GPLv2+ or Ruby's original".Closedmatz (Yukihiro Matsumoto)09/02/2009Actions
Is duplicate of Ruby master - Feature #2982: Ruby tries to link with both openssl and readlineThird Party's Issue03/18/2010Actions
Actions #2

Updated by naruse (Yui NARUSE) over 12 years ago

=begin
libedit doesn't support multibyte encodings.
=end

Actions #3

Updated by nobu (Nobuyoshi Nakada) over 12 years ago

  • Status changed from Open to Closed

=begin

=end

Actions #4

Updated by lucas (Lucas Nussbaum) over 12 years ago

=begin
I'm surprised this was closed without discussion. How do you recommend we (Debian) solve that?
=end

Actions #5

Updated by naruse (Yui NARUSE) over 12 years ago

  • Status changed from Closed to Open

=begin
GPL3 problem is not resolved; this ticket is mistakenly closed because this is duplicated ticket with #2982.
=end

Actions #6

Updated by wishdev (John Higgins) over 12 years ago

=begin
libedit might be finally getting multibyte encodings - http://cvsweb.netbsd.org/bsdweb.cgi/src/lib/libedit/?sortby=date - there appears to be a commit to add UTF-8 support
=end

Actions #7

Updated by naruse (Yui NARUSE) over 12 years ago

=begin
Yes, but current its UTF-8 support is broken.
Moreover it is only UTF-8.

I heard they are working on supporting M17N, so it is good when that is done.
=end

Actions #8

Updated by nobu (Nobuyoshi Nakada) over 12 years ago

  • Status changed from Open to Closed

=begin
I close this ticket because it is duplication.
Also, note that libedit has been supported already,
libreadline will be disabled by --enable-libedit configure option.
=end

Actions #9

Updated by naruse (Yui NARUSE) over 12 years ago

  • Status changed from Closed to Open

=begin
Don't close duplicated tickets, all of them are closed if you close one of them > nobu
=end

Actions #10

Updated by nobu (Nobuyoshi Nakada) over 12 years ago

  • ruby -v changed from 1.8 to *

=begin
At least, to avoid divergence, I don't think we should make discussions in many places.

=end

Actions #11

Updated by nobu (Nobuyoshi Nakada) over 12 years ago

  • Status changed from Open to Third Party's Issue

=begin

=end

Actions

Also available in: Atom PDF