Project

General

Profile

Feature #2635

Unbundle rdoc

Added by naruse (Yui NARUSE) almost 10 years ago. Updated over 8 years ago.

Status:
Rejected
Priority:
Normal
Target version:
[ruby-core:27722]

Description

=begin
The rdoc in trunk is outdated and not maintained,
and latest rdoc is in gen.

I think Ruby 1.9 shouldn't bundle such old rdoc.
People who needs rdoc should install from gem.
=end


Related issues

Related to Ruby master - Bug #883: Failure: test_handle_special_CROSSREF_no_underscore(TestRDocMarkupToHtmlCrossref)Closed12/15/2008Actions
Related to Ruby master - Bug #1042: RDoc crashes while generating HTML after parsing a Ruby DSL.Closed01/23/2009Actions
Related to Ruby master - Bug #1234: RDoc failure in benchmark/bm_so_meteor_contest.rb at or around line 542 columnClosed03/01/2009Actions
Related to Ruby master - Bug #1948: RDoc Fails with Non-ASCII PathnamesClosed08/18/2009Actions
Related to Ruby master - Bug #2066: Merge Latest RDoc/RiClosed09/09/2009Actions
Related to Ruby master - Feature #5481: Gemifying Ruby standard libraryAssignedActions

History

#1

Updated by matz (Yukihiro Matsumoto) almost 10 years ago

=begin
Hi,

In message "Re: [ruby-core:27722] [Feature #2635] Unbundle rdoc"
on Sat, 23 Jan 2010 23:20:59 +0900, Yui NARUSE redmine@ruby-lang.org writes:

|The rdoc in trunk is outdated and not maintained,
|and latest rdoc is in gen.
|
|I think Ruby 1.9 shouldn't bundle such old rdoc.
|People who needs rdoc should install from gem.

Or bundle newer rdoc?

                        matz.

=end

#2

Updated by naruse (Yui NARUSE) almost 10 years ago

=begin
Bug #2066 is written by Run Paint Run Run 136 days ago, but it is not yet.

Moreover rdoc has some open bugs for 1 year.
test-all failure and crash bugs need to fixed but not fixed.
I, maintaining Redmine's tickets, hate those unmaintained libraries.
=end

#3

Updated by matz (Yukihiro Matsumoto) almost 10 years ago

=begin
Hi,

In message "Re: [ruby-core:27725] [Feature #2635] Unbundle rdoc"
on Sun, 24 Jan 2010 00:15:33 +0900, Yui NARUSE redmine@ruby-lang.org writes:

|Moreover rdoc has some open bugs for 1 year.
|test-all failure and crash bugs need to fixed but not fixed.
|I, maintaining Redmine's tickets, hate those unmaintained libraries.

In that case, should we ask for new volunteer instead of removing it?

                        matz.

=end

#4

Updated by luislavena (Luis Lavena) almost 10 years ago

=begin
On Sat, Jan 23, 2010 at 12:15 PM, Yui NARUSE redmine@ruby-lang.org wrote:

Moreover rdoc has some open bugs for 1 year.
test-all failure and crash bugs need to fixed but not fixed.
I, maintaining Redmine's tickets, hate those unmaintained libraries.

Is my understanding that rdoc has been updated and maintained by Eric
Hodel, at least eh gem was.

If integration with Ruby is the problem, then removal and optional
installation for the user should be the solution, right?
--
Luis Lavena
AREA 17
-
Perfection in design is achieved not when there is nothing more to add,
but rather when there is nothing more to take away.
Antoine de Saint-Exupéry

=end

#5

Updated by naruse (Yui NARUSE) almost 10 years ago

=begin
(2010/01/24 0:35), Yukihiro Matsumoto wrote:

|Moreover rdoc has some open bugs for 1 year.
|test-all failure and crash bugs need to fixed but not fixed.
|I, maintaining Redmine's tickets, hate those unmaintained libraries.

In that case, should we ask for new volunteer instead of removing it?

If someone maintain rdoc lib in Ruby, it is clear.

--
NARUSE, Yui naruse@airemix.jp

=end

#6

Updated by matz (Yukihiro Matsumoto) almost 10 years ago

=begin
Hi,

In message "Re: [ruby-core:27729] Re: [Feature #2635] Unbundle rdoc"
on Sun, 24 Jan 2010 00:41:18 +0900, Luis Lavena luislavena@gmail.com writes:

|Is my understanding that rdoc has been updated and maintained by Eric
|Hodel, at least eh gem was.
|
|If integration with Ruby is the problem, then removal and optional
|installation for the user should be the solution, right?

That's what I don't understand. Eric has commit privilege. If he
still maintains rdoc gem, I see no reason he doesn't update the
bundled rdoc as well. If he stops maintaining rdoc, we need new
maintainer. If he keeps working on it, I expect him to update bundled
rdoc as well.

                        matz.

=end

#7

Updated by naruse (Yui NARUSE) almost 10 years ago

=begin
(2010/01/24 0:41), Luis Lavena wrote:

On Sat, Jan 23, 2010 at 12:15 PM, Yui NARUSE redmine@ruby-lang.org wrote:

Moreover rdoc has some open bugs for 1 year.
test-all failure and crash bugs need to fixed but not fixed.
I, maintaining Redmine's tickets, hate those unmaintained libraries.

Is my understanding that rdoc has been updated and maintained by Eric
Hodel, at least eh gem was.

I think so too.

If integration with Ruby is the problem, then removal and optional
installation for the user should be the solution, right?

Yeah, I think so.
rdoc is pure ruby, so it won't be a severe problem,
even if Ruby's installation process needs some changes.

--
NARUSE, Yui naruse@airemix.jp

=end

#8

Updated by mame (Yusuke Endoh) almost 10 years ago

=begin
Hi,

2010/1/23 Yukihiro Matsumoto matz@ruby-lang.org:

In message "Re: [ruby-core:27722] [Feature #2635] Unbundle rdoc"
on Sat, 23 Jan 2010 23:20:59 +0900, Yui NARUSE redmine@ruby-lang.org writes:

|The rdoc in trunk is outdated and not maintained,
|and latest rdoc is in gen.
|
|I think Ruby 1.9 shouldn't bundle such old rdoc.
|People who needs rdoc should install from gem.

Or bundle newer rdoc?

I don't know much about the "latest" rdoc, but according to [ruby-core:27667],
I understand that simply updating causes compatibility problem because:

The latest RDoc no longer has the HTML generator at all.

The reporter in [ruby-core:27656] followed proper reporting procedure (i.e.,
tested and patched against 1.9 trunk). Ruby's development process is wrong.
It is too confusing for rdoc to have independent trunk.
In [ruby-core:27667],

I fixed this memory issue by deleting the file.

is equal to "I fixed in my own envirionment!" It does not answer.

I wonder why some standard libraries (RubyGems, Rake, rdoc, etc.) need
to have independent development process and independent release.
I said in [ruby-core:26679], they should be developed and released with
ruby core if they are really parts of ruby core.

--
Yusuke ENDOH mame@tsg.ne.jp

=end

#9

Updated by zenspider (Ryan Davis) almost 10 years ago

=begin

On Jan 23, 2010, at 19:03 , Yusuke ENDOH wrote:

The reporter in [ruby-core:27656] followed proper reporting procedure (i.e.,
tested and patched against 1.9 trunk). Ruby's development process is wrong.
It is too confusing for rdoc to have independent trunk.

Then we should eject ALL of standard lib from trunk. Gemify all of them and kick them out the door.

Maybe we should bundle some gems, but they should install as actual gems and be freely upgradable by the user.

Like it or not, rdoc, minitest (and test/unit), rubygems, rexml, and yaml (and others?) are all separate products that are produced independent of trunk. In my opinion, it works BETTER that way, not worse. What doesn't work is having to slow down releases because ruby releases are so few and far between.

=end

#10

Updated by jbarnette (John Barnette) almost 10 years ago

=begin
On Sun, Jan 24, 2010 at 10:31 PM, Ryan Davis ryand-ruby@zenspider.com wrote:

Like it or not, rdoc, minitest (and test/unit), rubygems, rexml, and yaml (and others?) are all separate products that are produced independent of trunk. In my opinion, it works BETTER that way, not worse. What doesn't work is having to slow down releases because ruby releases are so few and far between.

Rake. Rex. Racc.

~ j.

=end

#11

Updated by naruse (Yui NARUSE) almost 10 years ago

=begin
On Mon, Jan 25, 2010 at 3:31 PM, Ryan Davis ryand-ruby@zenspider.com wrote:

On Jan 23, 2010, at 19:03 , Yusuke ENDOH wrote:

The reporter in [ruby-core:27656] followed proper reporting procedure (i.e.,
tested and patched against 1.9 trunk).  Ruby's development process is wrong.
It is too confusing for rdoc to have independent trunk.

Then we should eject ALL of standard lib from trunk. Gemify all of them and kick them out the door.

Maybe we should bundle some gems, but they should install as actual gems and be freely upgradable by the user.

Like it or not, rdoc, minitest (and test/unit), rubygems, rexml, and yaml (and others?) are all separate products that are produced independent of trunk. In my opinion, it works BETTER that way, not worse. What doesn't work is having to slow down releases because ruby releases are so few and far between.

I don't think it is a problem that some libraries are developed out of
Ruby's repos,
until the maintainer fixes bugs created in Ruby's Redmine and update
the lib in trunk.
Current minitest, nkf, JSON, is doing that. (I maintain nkf and JSON)
REXML, YAML, racc are note developed.
rake doesn't but not have reported bugs.

--
NARUSE, Yui
naruse@airemix.jp

=end

#12

Updated by mame (Yusuke Endoh) almost 10 years ago

=begin
Hi,

2010/1/25 Ryan Davis ryand-ruby@zenspider.com:

On Jan 23, 2010, at 19:03 , Yusuke ENDOH wrote:

The reporter in [ruby-core:27656] followed proper reporting procedure (i.e.,
tested and patched against 1.9 trunk). Ruby's development process is wrong.
It is too confusing for rdoc to have independent trunk.

In my opinion, it works BETTER that way, not worse.

It brings some benefits, but problems actually occur.

  • slow synchronization between the "latest" and ruby trunk
  • empty answer that the issue is fixed in the "latest"
  • neglect of tickets in ruby's redmine
  • incompatible change to the "latest"

These problems do not occur or are detected early if they
are developed in ruby trunk. Nobody would say anything if
such a problem does not occur, I think.

--
Yusuke ENDOH mame@tsg.ne.jp

=end

#13

Updated by naruse (Yui NARUSE) almost 10 years ago

  • Status changed from Assigned to Rejected

=begin

=end

#14

Updated by hsbt (Hiroshi SHIBATA) almost 3 years ago

  • Related to Feature #5481: Gemifying Ruby standard library added

Also available in: Atom PDF