Project

General

Profile

Bug #15853

Fix readline test regression when using Readline 4.3

Added by jeremyevans0 (Jeremy Evans) about 1 year ago. Updated about 1 year ago.

Status:
Closed
Priority:
Normal
Target version:
-
[ruby-core:92676]

Description

c754e979d3eeca51f1b13778f19f347df3da656e removed the check for Readline 4.3 in a test. Previously, the whole test was skipped on Readline 4.3. However, it turns out that Readline 4.3 runs the test correctly if you skip the same assertion that is skipped when Reline is used. The attached patch skips that assertion when Readline::VERSION is 4.3.

We may want to consider dropping this assertion completely, it seems to be readline implementation and version dependent behavior.


Files

fix-readline-4.3-test-regression.patch (1.3 KB) fix-readline-4.3-test-regression.patch jeremyevans0 (Jeremy Evans), 05/16/2019 04:14 AM
fix-readline-4.3-test-regression-v2.patch (1.28 KB) fix-readline-4.3-test-regression-v2.patch jeremyevans0 (Jeremy Evans), 05/16/2019 04:52 AM
fix-readline-4.3-test-regression-v3.patch (1.33 KB) fix-readline-4.3-test-regression-v3.patch jeremyevans0 (Jeremy Evans), 05/17/2019 02:58 PM

Also available in: Atom PDF