Project

General

Profile

Actions

Backport #8080

closed

Segfault in rb_fd_set

Added by jonleighton (Jon Leighton) over 9 years ago. Updated over 9 years ago.

Status:
Closed
Priority:
Normal
[ruby-core:53349]

Description

I have experienced a segfault with Ruby 2 during an IO.select call:

See https://travis-ci.org/jonleighton/spring/jobs/5393025 or https://gist.github.com/jonleighton/5147785 to see the crash output.

I cannot reproduce on a different version of Linux (Fedora). However I was able to reproduce by downloading a VM image of the Travis CI environment and running the code on there (see http://pivotallabs.com/debugging-travis-builds/ for how to do that).

I tried to produce a simple script to reproduce, but without success. I also tried to build Ruby 2 with debugging symbols, but this did not produce the crash. I'm not sure why - perhaps related to compiler optimisations.

I found a workaround for the crash with https://github.com/jonleighton/spring/commit/c8a7afdd3238ef88bffc2c8f56baa21042400e15.


Related issues 1 (0 open1 closed)

Has duplicate Ruby master - Bug #6653: 1.9.2/1.9.3 exhibit SEGV with many threads+tcp connectionsClosedakr (Akira Tanaka)06/27/2012Actions
Actions

Also available in: Atom PDF