Project

General

Profile

Actions

Feature #5610

closed

Allow strings as input for Process.uid=

Added by shevegen (Robert A. Heiler) over 10 years ago. Updated about 10 years ago.

Status:
Closed
Priority:
Normal
Target version:
[ruby-core:40923]

Description

On my unix system I often have a "debug" user account, belonging to the "debug" group.

With:

Process.euid

You can find out the effective uid and you can change it via =.

Process.euid = 522

That works. Today I tried to do this though:

Process.euid = "debug"

It does not work because .euid= wants a string.

Would it not be better to be more flexible than that? Internally it
could be converted into a number anyway as /etc/passwd can be
read. And if it can not be converted, an exception could be raised.

At least for me that would be quite convenient, no idea if this has
merit for others, but then again it is just a proposal. :)

Thank you for reading.


Files

Updated by shevegen (Robert A. Heiler) over 10 years ago

Oops, sorry. Not a bug, but a feature request. Hmm not sure how to change it ...

Updated by drbrain (Eric Hodel) over 10 years ago

  • Tracker changed from Bug to Feature
  • Category set to core
  • Priority changed from 3 to Normal
  • Target version set to 2.0.0

Updated by kosaki (Motohiro KOSAKI) over 10 years ago

The request looks make sense to me.

Updated by mame (Yusuke Endoh) about 10 years ago

  • Status changed from Open to Assigned
  • Assignee set to kosaki (Motohiro KOSAKI)

Kosaki-san,

Are you interested in creating a patch?

--
Yusuke Endoh

Updated by nobu (Nobuyoshi Nakada) about 10 years ago

=begin
Since (({Process.groups=})) already accepts strings, this proposal sounds reasonable.
=end

Actions #6

Updated by nobu (Nobuyoshi Nakada) about 10 years ago

  • Status changed from Assigned to Closed
  • % Done changed from 0 to 100

This issue was solved with changeset r35158.
markus, thank you for reporting this issue.
Your contribution to Ruby is greatly appreciated.
May Ruby be with you.


Actions

Also available in: Atom PDF