Project

General

Profile

Backport #5325

Bug in win32.c CreateChild

Added by jfrench (James French) almost 9 years ago. Updated about 4 years ago.

Status:
Rejected
Priority:
Normal
[ruby-core:39550]

Description

Hi,

Revision 31811 by yugui (http://svn.ruby-lang.org/cgi-bin/viewvc.cgi?view=revision&revision=31811) which was merged from the trunk contains a bug. It should be lstrlen instead of lstrlenW as its a char* not a wchar_t*. This has caused us a lot of problems with spawn failing spuriously.

This should really be corrected on the 1.9.2 branch (it looks like the code has moved on on the trunk and its not an issue).

Given that its a one character change and I'm not set up for submitting patches would someone be able to fix this for me?

As a side note, compiling with warnings as errors would have caught this....

When is the next 1.9.2 patch release due?

Cheers,
James

Updated by usa (Usaku NAKAMURA) almost 9 years ago

  • Category set to core
  • Status changed from Open to Assigned
  • Assignee set to yugui (Yuki Sonoda)
  • Target version set to 1.9.2

this is backport bug.

Index: win32/win32.c

--- win32/win32.c (revision 33270)
+++ win32/win32.c (working copy)
@@ -1040,7 +1040,7 @@ CreateChild(const char *cmd, const char

 dwCreationFlags = (NORMAL_PRIORITY_CLASS);
  • if (lstrlenW(cmd) > 32767) {
  • if (strlen(cmd) > 32767) { child->pid = 0; /* release the slot */ errno = E2BIG; return NULL;
#2

Updated by marcandre (Marc-Andre Lafortune) over 8 years ago

  • Status changed from Assigned to Closed

Duplicate of #5325

Updated by marcandre (Marc-Andre Lafortune) over 8 years ago

  • Status changed from Closed to Open
  • Target version changed from 1.9.2 to 2.0.0

I didn't realize redmine would close all duplicates. Sorry for the noise.

#4

Updated by shyouhei (Shyouhei Urabe) over 8 years ago

  • Status changed from Open to Assigned
#5

Updated by mame (Yusuke Endoh) about 8 years ago

  • Tracker changed from Bug to Backport
  • Project changed from Ruby master to Backport192
  • Category changed from core to core
  • Target version deleted (2.0.0)
#6

Updated by naruse (Yui NARUSE) about 4 years ago

  • Status changed from Assigned to Rejected

Also available in: Atom PDF