Project

General

Profile

Bug #3749

-rtracer doesn't trace anymore

Added by rogerdpack (Roger Pack) about 7 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Normal
Target version:
-
ruby -v:
ruby 1.9.3dev (2010-08-26 trunk 29104) [i386-mingw32]
[ruby-core:31858]

Description

=begin
$ cat bad.rb

a = [1,2,3]
a.each{|n|
p n
}
$ ruby -vrtracer bad.rb
ruby 1.9.3dev (2010-08-26 trunk 29104) [i386-mingw32]
1
2
3
=end


Related issues

Is duplicate of Ruby trunk - Bug #3843: ruby -r tracer prog.rb no longer tracers prog.rbClosed2010-09-17

History

#1 Updated by shyouhei (Shyouhei Urabe) about 7 years ago

  • Status changed from Open to Assigned
  • Assignee set to ko1 (Koichi Sasada)

=begin

=end

#2 Updated by nobu (Nobuyoshi Nakada) about 7 years ago

  • Status changed from Assigned to Closed
  • % Done changed from 0 to 100

=begin
This issue was solved with changeset r29280.
Roger, thank you for reporting this issue.
Your contribution to Ruby is greatly appreciated.
May Ruby be with you.

=end

Also available in: Atom PDF