Project

General

Profile

Actions

Bug #3480

closed

gem_prelude: activation should accomodate for '=' and gem 'gem_name', 'version'

Added by rogerdpack (Roger Pack) about 12 years ago. Updated about 11 years ago.

Status:
Rejected
Priority:
Normal
Target version:
ruby -v:
ruby 1.9.3dev (2010-06-22) [i386-mingw32]
Backport:

Description

=begin
Hi all.
Noticed that currently gem_prelude.rb doesn't allow for gem activation like:

gem 'gem_name', '2.3.8'

nor

gem 'gem_name', '= 2.3.8'

The attached patch attempts to remedy this unseemly condition.
Cheers!
-r
=end


Files

gem_prelude_accomodate.diff (8.22 KB) gem_prelude_accomodate.diff rogerdpack (Roger Pack), 06/25/2010 11:13 AM

Related issues 1 (0 open1 closed)

Related to Ruby master - Bug #3617: respond_to?(:gem) is false in 1.9.2-rc2Rejected07/26/2010Actions
Actions

Also available in: Atom PDF