Project

General

Profile

Feature #2084

Method#source_location and Methods Created with `attr`

Added by runpaint (Run Paint Run Run) about 11 years ago. Updated over 9 years ago.

Status:
Closed
Priority:
Normal
Target version:
[ruby-core:25532]

Description

=begin
$ cat /tmp/attr.rb
class C
attr :a
end

p C.instance_methods(false)
p C.instance_method(:a).source_location

$ ruby -v /tmp/attr.rb
ruby 1.9.2dev (2009-09-11) [i686-linux]
[:a]
nil

Is it feasible to have Method#source_location work with methods created with attr(and friends)? Given that a common use for this feature is to extract documentation, it would be helpful if such methods could be located by introspection.
=end


Files

save_attr_loc.patch (5.1 KB) save_attr_loc.patch wanabe (_ wanabe), 01/25/2010 09:56 AM
#1

Updated by wanabe (_ wanabe) over 10 years ago

=begin
I wrote a patch. How about this?
=end

#2

Updated by nobu (Nobuyoshi Nakada) over 10 years ago

  • Status changed from Open to Assigned
  • Assignee set to yugui (Yuki Sonoda)

=begin

=end

#3

Updated by mame (Yusuke Endoh) over 10 years ago

  • Priority changed from 3 to Normal
  • Target version set to 1.9.2

=begin
Hi,

I wrote a patch. How about this?

+1, and I confirmed it passes make check and RubySpec.

Matz or Yugui, could you approve this?

--
Yusuke Endoh mame@tsg.ne.jp
=end

#4

Updated by mame (Yusuke Endoh) over 10 years ago

  • Assignee changed from yugui (Yuki Sonoda) to wanabe (_ wanabe)

=begin
Hi,

Matz or Yugui, could you approve this?

Yugui has agreed with this feature on IRC.
But she said she had no responsibility for Method#source_location.
(I had misunderstood that she had committed it)

Well, because this feature is trivial, I guess anyone won't disagree.
Wanabe, could you apply your patch?
If you are reluctant to commit it without explicit approval, I'll
commit it on my own responsibility.

--
Yusuke Endoh mame@tsg.ne.jp
=end

#5

Updated by wanabe (_ wanabe) over 10 years ago

=begin

If you are reluctant to commit it without explicit approval, I'll
commit it on my own responsibility.

Many thanks for your concern.
I'll apply it soon.
=end

#6

Updated by wanabe (_ wanabe) over 10 years ago

  • Status changed from Assigned to Closed
  • % Done changed from 0 to 100

=begin
This issue was solved with changeset r27016.
Run Paint, thank you for reporting this issue.
Your contribution to Ruby is greatly appreciated.
May Ruby be with you.

=end

Also available in: Atom PDF