Project

General

Profile

Bug #12349

Can't load OpenStruct with Syck with Ruby 2.3.x

Added by PSchambacher (Pierre Schambacher) about 3 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Normal
Target version:
-
ruby -v:
ruby 2.3.1p112 (2016-04-26 revision 54768) [x86_64-darwin15]
[ruby-core:75354]

Description

This is the same kind of problem that happened with Psych here: https://bugs.ruby-lang.org/issues/11884

When trying to load an OpenStruct object using Syck, the @table instance variable is nil, making the has_key? method fail in respond_to_missing?

I'm assigning to Aaron Patterson for triaging.


Files

syck_error.log (635 Bytes) syck_error.log stack trace PSchambacher (Pierre Schambacher), 05/04/2016 10:39 PM
syck_error.rb (101 Bytes) syck_error.rb reproduction script PSchambacher (Pierre Schambacher), 05/04/2016 10:39 PM

Related issues

Is duplicate of Ruby master - Bug #11884: Psych.load broken for OpenStruct in Ruby 2.3.0ClosedActions

History

Updated by hsbt (Hiroshi SHIBATA) about 3 years ago

  • Status changed from Open to Third Party's Issue

Syck is not part of ruby core. Please submit your issue to https://github.com/tenderlove/syck

#2

Updated by marcandre (Marc-Andre Lafortune) about 3 years ago

  • Is duplicate of Bug #12136: OpenStruct.new(format: :bar).send :format # => too few arguments added
#3

Updated by marcandre (Marc-Andre Lafortune) about 3 years ago

  • Is duplicate of deleted (Bug #12136: OpenStruct.new(format: :bar).send :format # => too few arguments)
#4

Updated by marcandre (Marc-Andre Lafortune) about 3 years ago

  • Is duplicate of Bug #11884: Psych.load broken for OpenStruct in Ruby 2.3.0 added

Updated by marcandre (Marc-Andre Lafortune) about 3 years ago

  • Status changed from Third Party's Issue to Closed

This has already been reported in #11884, thanks

Also available in: Atom PDF