Bug #9690


Better orror message for config.guess downloading

Added by duerst (Martin Dürst) over 8 years ago. Updated over 8 years ago.

Target version:
ruby -v:
ruby 2.0.0p353 (this is baseruby)


I recently tried to compile Ruby on a new machine and got the error below:

Trying again today, it suddenly worked, but I think it would be great if there were a better error message. "getaddrinfo: Name or service not known (SocketError)" doesn't even say what it tried to download. Knowing what it tried to download could easily help to try download it by hand, see if the system is actually connected to the outside, and so on.

Downloading config.guess.../usr/share/ruby/net/http.rb:878:in initialize': getaddrinfo: Name or service not known (SocketError) from /usr/share/ruby/net/http.rb:878:in open'
from /usr/share/ruby/net/http.rb:878:in block in connect' from /usr/share/ruby/timeout.rb:52:in timeout'
from /usr/share/ruby/net/http.rb:877:in connect' from /usr/share/ruby/net/http.rb:862:in do_start'
from /usr/share/ruby/net/http.rb:851:in start' from /usr/share/ruby/open-uri.rb:313:in open_http'
from /usr/share/ruby/open-uri.rb:708:in buffer_open' from /usr/share/ruby/open-uri.rb:210:in block in open_loop'
from /usr/share/ruby/open-uri.rb:208:in catch' from /usr/share/ruby/open-uri.rb:208:in open_loop'
from /usr/share/ruby/open-uri.rb:149:in open_uri' from /usr/share/ruby/open-uri.rb:688:in open'
from /usr/share/ruby/open-uri.rb:696:in read' from /home/duerst/ruby/tool/config_files.rb:5:in download'
from get-config_files:5:in block in <main>' from get-config_files:3:in each'
from get-config_files:3:in `'
checking build system type... /bin/sh: tool/config.guess: No such file or directory
configure: error: cannot guess build type; you must specify one

Updated by nobu (Nobuyoshi Nakada) over 8 years ago

  • Status changed from Open to Closed
  • % Done changed from 0 to 100

Applied in changeset r45494.

config_files.rb: show failure

Updated by usa (Usaku NAKAMURA) over 8 years ago

  • Backport changed from 2.0.0: UNKNOWN, 2.1: UNKNOWN to 2.0.0: DONTNEED, 2.1: UNKNOWN

Updated by nagachika (Tomoyuki Chikanaga) over 8 years ago

  • Backport changed from 2.0.0: DONTNEED, 2.1: UNKNOWN to 2.0.0: DONTNEED, 2.1: WONTFIX

Also available in: Atom PDF