Project

General

Profile

Bug #8759

Error compiling miniruby

Added by spastorino (Santiago Pastorino) almost 7 years ago. Updated almost 7 years ago.

Status:
Closed
Priority:
Normal
Target version:
-
ruby -v:
ruby 2.1.0dev (2013-08-09 trunk 42459) [x86_64-darwin12.4.0]
[ruby-core:56467]

Description

I'm getting an error compiling miniruby after this change https://github.com/ruby/ruby/commit/c04f402f0f7692f6105c930f19d81b332d6a93d5 nobu added ...

linking miniruby
Undefined symbols for architecture x86_64:
"_CFRelease", referenced from:
_rb_str_normalize_ospath in file.o
"_CFStringCreateMutableCopy", referenced from:
_rb_str_normalize_ospath in file.o
"_CFStringCreateWithBytesNoCopy", referenced from:
_rb_str_normalize_ospath in file.o
"_CFStringGetBytes", referenced from:
_rb_str_normalize_ospath in file.o
"_CFStringGetLength", referenced from:
_rb_str_normalize_ospath in file.o
"_CFStringNormalize", referenced from:
_rb_str_normalize_ospath in file.o
"_kCFAllocatorDefault", referenced from:
_rb_str_normalize_ospath in file.o
"_kCFAllocatorNull", referenced from:
_rb_str_normalize_ospath in file.o
ld: symbol(s) not found for architecture x86_64
clang: error: linker command failed with exit code 1 (use -v to see invocation)
make: *** [miniruby] Error 1

Patch attached


Files

config.patch (549 Bytes) config.patch spastorino (Santiago Pastorino), 08/09/2013 04:12 PM

Updated by naruse (Yui NARUSE) almost 7 years ago

  • Status changed from Open to Feedback
  • Backport changed from 1.9.3: UNKNOWN, 2.0.0: UNKNOWN to 1.9.3: DONTNEED, 2.0.0: DONTNEED

I can't reproduce it and r42457 includes such configure.in changes.
Could you confirm there's something wrong?

Updated by charliesome (Charlie Somerville) almost 7 years ago

Santiago, do you already have the CFLAGS or LDFLAGS environment variables set in your shell when you invoke ./configure?

Updated by charliesome (Charlie Somerville) almost 7 years ago

I can reproduce this locally. I believe this is the problem: #8762

#4

Updated by nobu (Nobuyoshi Nakada) almost 7 years ago

  • Status changed from Feedback to Closed
  • % Done changed from 0 to 100

This issue was solved with changeset r42472.
Santiago, thank you for reporting this issue.
Your contribution to Ruby is greatly appreciated.
May Ruby be with you.


configure.in: CoreFoundation framework option

  • configure.in (XLDFLAGS, LIBRUBYARG_STATIC): CoreFoundation framework option is now needed always, regardless enable-shared. [ruby-core:56467] [Bug #8759]

Also available in: Atom PDF