Project

General

Profile

Bug #7949

Gem::Ext::Builder removes dependency to directory creation task

Added by masarakki (masaki yamada) over 7 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Normal
Target version:
ruby -v:
ruby 2.0.0p0 (2013-02-24 revision 39474) [x86_64-linux]
Backport:
[ruby-dev:47101]

Description

lib/rubygems/ext/builder.rb:22 removes dependency to ./RUBYARCHDIR.time,
so lib directory creation task won't be run.

thus for instance when tried to install rubyzip.gem which doesn't have lib directory,
rubygem makes binary file "lib" not lib/zipruby.so.

site_ruby/2.0.0/rubygems/ext/builder.rb の22行目の処理で、
install-so タスクが ./.RUBYARCHDIR.time に依存しているという情報が消されてしまうので、
libディレクトリの作成タスクが走らなくなっています。

libディレクトリを持たないgem(具体的には zipruby)を gem install でインストールすると、
lib/zipruby.so ではなく lib というバイナリファイルが作られます。


Related issues

Is duplicate of Ruby master - Bug #7698: RubyGems 2.0 has an incompatibility about installation of extension librariesClosednobu (Nobuyoshi Nakada)01/15/2013Actions

Also available in: Atom PDF