Project

General

Profile

Actions

Bug #7313

closed

test_initialize(TestEnumerator) fails

Added by vo.x (Vit Ondruch) over 9 years ago. Updated over 9 years ago.

Status:
Closed
Priority:
Normal
Target version:
ruby -v:
ruby 2.0.0dev (2012-11-08 trunk 37564) [x86_64-linux]
Backport:
[ruby-core:49107]

Description

=begin
test_initialize(TestEnumerator):
TypeError: can't convert Array into Integer
/builddir/build/BUILD/ruby-2.0.0-r37564/test/ruby/test_enumerator.rb:72:in initialize' /builddir/build/BUILD/ruby-2.0.0-r37564/test/ruby/test_enumerator.rb:72:in new'
/builddir/build/BUILD/ruby-2.0.0-r37564/test/ruby/test_enumerator.rb:72:in `test_initialize'
=end


Related issues 1 (0 open1 closed)

Is duplicate of Ruby master - Bug #7298: Behavior of Enumerator.new different between 1.9.3 and 2.0.0Closedayumin (Ayumu AIZAWA)11/07/2012Actions

Updated by mame (Yusuke Endoh) over 9 years ago

  • Status changed from Open to Assigned
  • Assignee set to marcandre (Marc-Andre Lafortune)
  • Target version set to 2.0.0

Marc-Andre, do you know anything about this?

--
Yusuke Endoh

Updated by marcandre (Marc-Andre Lafortune) over 9 years ago

  • Status changed from Assigned to Closed

Duplicate of #7298, see [ruby-core:49077]

Actions

Also available in: Atom PDF