Bug #7277

mingw: Makefile no longer links ruby.res.o with PROGRAM or WPROGRAM

Added by luislavena (Luis Lavena) almost 8 years ago. Updated almost 8 years ago.

Target version:
ruby -v:
ruby 2.0.0dev (2012-11-01) [x64-mingw32]


Just recently noticed that when linking ruby.exe or rubyw.exe, the icon defined in ruby.rc (or rubyw.rc) is not linked in.

The following is the command line make ruby.exe V=1 generates:

x86_64-w64-mingw32-gcc -O3 -fno-omit-frame-pointer -fno-fast-math -g -Wall -Wextra -Wno-unused-parameter -Wno-parentheses -Wno-long-long -Wno-missing-field-initializers -Wunused-variable -Werror=pointer-arith -Werror=write-strings -Werror=declaration-after-statement -Werror=implicit-function-declaration -L. -LC:/Users/Luis/Code/oneclick/rubyinstaller/sandbox/tk/lib -LC:/Users/Luis/Code/oneclick/rubyinstaller/sandbox/tcl/lib -LC:/Users/Luis/Code/oneclick/rubyinstaller/sandbox/zlib/lib -LC:/Users/Luis/Code/oneclick/rubyinstaller/sandbox/libyaml/lib -LC:/Users/Luis/Code/oneclick/rubyinstaller/sandbox/pdcurses/lib -LC:/Users/Luis/Code/oneclick/rubyinstaller/sandbox/openssl/lib -LC:/Users/Luis/Code/oneclick/rubyinstaller/sandbox/iconv/lib -LC:/Users/Luis/Code/oneclick/rubyinstaller/sandbox/gdbm/lib -LC:/Users/Luis/Code/oneclick/rubyinstaller/sandbox/libffi/lib -Wl,--stack,0x00200000,--enable-auto-import main.o -lx64-msvcrt-ruby200 -lshell32 -lws2_32 -limagehlp -lshlwapi -o ruby.exe

However is not linking ruby.res.o with it.

This seems to be unique to trunk as ruby_1_9_3 still was able to associate the icon with the executable.

Also this didn't affect DLL creation, as it still included the rc information for it (it linked properly)

Any ideas?

Thank you


Updated by Anonymous almost 8 years ago

  • Status changed from Assigned to Closed
  • % Done changed from 0 to 100

This issue was solved with changeset r37475.
Luis, thank you for reporting this issue.
Your contribution to Ruby is greatly appreciated.
May Ruby be with you.

  • cygwin/ ( link *.res.o. EXTOBJES is defined in *.res.o setting should be below [ruby-core:48858] [Bug #7277]

Updated by h.shirosaki (Hiroshi Shirosaki) almost 8 years ago

Luis, I fixed at r37475. Please check it.

Updated by luislavena (Luis Lavena) almost 8 years ago

h.shirosaki (Hiroshi Shirosaki) wrote:

Luis, I fixed at r37475. Please check it.

Thank you Hiroshi, worked like a charm.

I'll release 2.0.0-preview1 as is mentioning this small detail in the experimental notes.

Thank you again.

Also available in: Atom PDF