Bug #6897


With --no-retry option parallel test-all result

Added by h.shirosaki (Hiroshi Shirosaki) almost 10 years ago. Updated over 9 years ago.

Target version:
ruby -v:
ruby 2.0.0dev (2012-08-20 trunk 36737) [x86_64-linux]


With --no-retry option, parallel test-all result looks strange as below.
I actually see a test error with ubuntu linux bundled openssl. I show this by another reproducible example.

For example:
Add a raise to emulate error.

diff --git a/test/openssl/test_ssl.rb b/test/openssl/test_ssl.rb
index 97a3a46..44f3fed 100644
--- a/test/openssl/test_ssl.rb
+++ b/test/openssl/test_ssl.rb
@@ -4,6 +4,7 @@ if defined?(OpenSSL)

class OpenSSL::TestSSL < OpenSSL::SSLTestCase
def test_ctx_setup

  • raise OpenSSL::SSL::SSLError
    ctx =
    assert_equal(ctx.setup, true)
    assert_equal(ctx.setup, nil)

$ make test-all TESTS="-j3 --no-retry openssl/test_ssl.rb"

[1/1] 87748:ready 87749:ready 87750=test_sslFinished tests in 1.512269s, 18.5152 tests/s, 187.7973 assertions/s.

  1. Error:
    OpenSSL::SSL::SSLError: OpenSSL::SSL::SSLError
    /Users/hiroshi/src/ruby/test/openssl/test_ssl.rb:7:in `test_ctx_setup'

  2. E
    28 tests, 284 assertions, 0 failures, 2 errors, 0 skips

I attached a patch which contains fixes as below.

  • delete status line
  • remove reports like 2) E
  • correct failures/errors/skips counts

Above example doesn't complete unless #6882 is solved. So attatched patch contains fixes for #6882.


0001-Fix-parallel-test-no-retry-option.patch (2.63 KB) 0001-Fix-parallel-test-no-retry-option.patch h.shirosaki (Hiroshi Shirosaki), 08/21/2012 12:16 AM

Related issues 1 (0 open1 closed)

Related to Ruby master - Bug #6882: parallel test crashes when unknown exception is occured in a testClosedusa (Usaku NAKAMURA)08/16/2012Actions

Updated by usa (Usaku NAKAMURA) almost 10 years ago

  • Description updated (diff)
  • Status changed from Open to Assigned

format description

Actions #2

Updated by sorah (Sorah Fukumori) over 9 years ago

  • Status changed from Assigned to Closed
  • % Done changed from 0 to 100

This issue was solved with changeset r37425.
Hiroshi, thank you for reporting this issue.
Your contribution to Ruby is greatly appreciated.
May Ruby be with you.

  • lib/test/unit.rb (_run_parallel): Delete status line before showing
    results. Patch by Hiroshi Shirosaki. [Bug #6897] [ruby-core:47250]

  • lib/test/unit.rb (_run_parallel): Fix strange result when disabled retrying.
    Patch by Hiroshi Shirosaki. [Bug #6897] [ruby-core:47250]


Also available in: Atom PDF