Project

General

Profile

Bug #6084

Ruby 1.9.3p125 Segfault while running nanoc compile

Added by Phrozen (Guillermo Estrada) over 8 years ago. Updated almost 8 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Target version:
ruby -v:
ruby 1.9.3p125 (2012-02-16) [i386-mingw32]
Backport:
[ruby-core:42901]

Description

Ruby interpreter segfaults with the compile command of nanoc for Ruby 1.9.3p125 under Windows. My windows version is Windows 7 Professional x64. While having checked with nanoc developer, this error does not appear on 1.9.3p0, and it is consistent with p125 under different windows machines, I don't think it can be reproduced easily with a new nanoc project, but I have several working projects that ran fine with 1.9.3p0 and each one of them segfaults in one or other place.


Files

SegfaultNanocWindows.txt (16.6 KB) SegfaultNanocWindows.txt Phrozen (Guillermo Estrada), 02/25/2012 03:05 PM

Updated by naruse (Yui NARUSE) over 8 years ago

  • Priority changed from 5 to Normal

Could you show the small reproducible code?

Updated by ktsj (Kazuki Tsujimoto) over 8 years ago

  • Status changed from Open to Feedback

Updated by jonforums (Jon Forums) over 8 years ago

I can't replicate with 1.9.3p134 or 1.9.3p155 [i386-mingw32] versions on Win7 32bit. One of my nanoc sites has a Rules file using erubis, redcarpet, and colorize_syntax https://github.com/thecodeshop/ruby/blob/gh-pages/_site_src/Rules

For your smallest failing nanoc project, please post a gist/hastebin of your Rules file, any custom Nanoc helpers, output of gem env, and your installed gems.

Updated by mame (Yusuke Endoh) almost 8 years ago

  • Status changed from Feedback to Rejected

Closing this ticket because it is too clueless.
OP seems to be gone. I guess we cannot get a feedback.

--
Yusuke Endoh mame@tsg.ne.jp

Also available in: Atom PDF