Project

General

Profile

Bug #5619

Segfault on OS X

Added by mutru (Otto Hilska) about 6 years ago. Updated almost 5 years ago.

Status:
Closed
Priority:
Normal
Target version:
ruby -v:
ruby 2.0.0dev (2012-03-10 trunk 34964) [x86_64-darwin11.3.0]
[ruby-core:40943]

Description

When I run 'roadie' gem specs on OS X, Ruby 1.9.3p0 segfaults.

Here's how to reproduce:

$ rvm use 1.9.3
$ git clone git://github.com/Mange/roadie.git
$ cd roadie
$ bundle install
$ bundle exec rake

I've attached the command output and the crash report.

It seems it might be a nokogiri issue, but since nokogiri's own tests run fine, I'm not sure.

This is my environment:

$ uname -a
Darwin becherovkax.local 11.2.0 Darwin Kernel Version 11.2.0: Tue Aug 9 20:54:00 PDT 2011; root:xnu-1699.24.8~1/RELEASE_X86_64 x86_64
$ ruby -v
ruby 1.9.3p0 (2011-10-30 revision 33570) [x86_64-darwin11.2.0]

It also happens with current 1.9.3-head (installed from RVM):
ruby 1.9.3p0 (2011-11-08 revision 33661) [x86_64-darwin11.2.0]

However, everything works fine on Linux.

roadie-crash.txt (74.9 KB) roadie-crash.txt Console output with a stacktrace mutru (Otto Hilska), 11/11/2011 11:18 PM
osx_ruby_crash_report_roadie.crash (15.9 KB) osx_ruby_crash_report_roadie.crash OS X crash report mutru (Otto Hilska), 11/11/2011 11:18 PM
valgrind-log.txt (219 KB) valgrind-log.txt valgrind run output mutru (Otto Hilska), 11/13/2011 08:27 PM
ruby_2011-11-14-154022_valo-mac.crash (19.6 KB) ruby_2011-11-14-154022_valo-mac.crash OS X crash report valo (Valentin Mihov), 11/14/2011 10:48 PM
crash_output.txt (72.7 KB) crash_output.txt crash output valo (Valentin Mihov), 11/14/2011 10:48 PM

History

#1 [ruby-core:40947] Updated by kosaki (Motohiro KOSAKI) about 6 years ago

Seems memory curruption issue.
Can you try valgrind or other memory error detection tools?

#2 [ruby-core:40961] Updated by nobu (Nobuyoshi Nakada) about 6 years ago

Seems libxml related finalizer issue.

#3 [ruby-core:40981] Updated by mutru (Otto Hilska) about 6 years ago

Here's what I get running valgrind. Let me know if I should enable some extra checks.

#4 [ruby-core:40986] Updated by kosaki (Motohiro KOSAKI) about 6 years ago

  • ruby -v changed from ruby 1.9.3p0 (2011-10-30 revision 33570) [x86_64-darwin11.2.0] to -

File valgrind-log.txt added

Here's what I get running valgrind. Let me know if I should enable some extra checks.

Hmmm.. This seems to don't have a useful hint.

#5 [ruby-core:41018] Updated by valo (Valentin Mihov) about 6 years ago

I verified the segmentation fault on the same version of OS X with ruby 1.9.3. I am attaching the crash report from OS X and the output on the command line. I will try later to run it through valgrind and see if I can find anything there...

#6 [ruby-core:43213] Updated by mrkn (Kenta Murata) almost 6 years ago

  • Assignee set to mrkn (Kenta Murata)

#7 [ruby-core:43235] Updated by mrkn (Kenta Murata) almost 6 years ago

  • Target version changed from 1.9.3 to 2.0.0
  • ruby -v changed from - to ruby 2.0.0dev (2012-03-10 trunk 34964) [x86_64-darwin11.3.0]

#8 Updated by shyouhei (Shyouhei Urabe) almost 6 years ago

  • Status changed from Open to Assigned

#9 [ruby-core:51300] Updated by mrkn (Kenta Murata) almost 5 years ago

  • Status changed from Assigned to Closed

I couldn't reproduce this issue on the latest trunk, r38731.
It may be fixed on the current trunk, I think.

Also available in: Atom PDF