Project

General

Profile

Actions

Bug #4619

closed

io.c is broken on Windows

Added by usa (Usaku NAKAMURA) over 11 years ago. Updated over 11 years ago.

Status:
Closed
Priority:
Normal
Target version:
ruby -v:
ruby 1.9.3dev (2011-04-27 trunk 31365) [x64-mswin64_100]
Backport:
[ruby-dev:<unknown>]

Description

=begin
r31355 以降、textmodeサポートがぶっ壊れてます。
(n)make testでテストが失敗しますし、test-allの方もEになりまくりです。
正直こんなもんrevertしろよって気分ですが、直せるあてはありますか?

make testの失敗:
#339 test_literal.rb: echo foo #=> "foo\r\n" (expected "foo\n")
#340 test_literal.rb: s = "foo"; echo #{s} #=> "foo\r\n" (expected "foo\n")

make test-allのEの抜粋:
Encoding::ConverterNotFoundError: code converter not found (universal_newline,crlf_newline)

=end


Related issues 1 (0 open1 closed)

Is duplicate of Ruby master - Bug #4618: Encoding::ConverterNotFoundErrors on trunk (Windows mingw)Closednobu (Nobuyoshi Nakada)04/27/2011Actions
Actions #1

Updated by nobu (Nobuyoshi Nakada) over 11 years ago

  • Status changed from Assigned to Closed
  • % Done changed from 0 to 100

=begin
This issue was solved with changeset r31367.
Usaku, thank you for reporting this issue.
Your contribution to Ruby is greatly appreciated.
May Ruby be with you.


  • io.c (rb_io_extract_modeenc, rb_f_backquote): set default text
    mode. fixes #4619
  • io.c (pipe_open): set universal newline decorator if needed.
    =end

Updated by usa (Usaku NAKAMURA) over 11 years ago

  • Status changed from Closed to Assigned

=begin
test-allのエラーはまったく直ってないので、再オープンしときます。
現状、これに起因すると思われるエラーが私の手元では95個あります。
=end

Actions #3

Updated by nobu (Nobuyoshi Nakada) over 11 years ago

  • Status changed from Assigned to Closed

=begin
This issue was solved with changeset r31377.
Jon, thank you for reporting this issue.
Your contribution to Ruby is greatly appreciated.
May Ruby be with you.


  • io.c (make_writeconv): do not add textmode newline decorator if any
    newline decorator is set already. fixes #4618, fixes #4619
    =end
Actions

Also available in: Atom PDF

Like0
Like0Like0Like0