Project

General

Profile

Backport #3665

RUBY Constant Update ( for ver < 1.8.7 ) - Pure Ruby patch

Added by DanRathbun (Dan Rathbun) almost 9 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Normal
[ruby-core:31641]

Description

=begin
Updates older Ruby versions to have constants
like 1.8.7 and 1.9.x, specifically:

RUBY_COPYRIGHT, RUBY_DESCRIPTION and
RUBY_PATCHLEVEL if less than ver 1.8.5-p12

Registered in old system as: ID 28451
http://rubyforge.org/tracker/index.php?func=detail&aid=28451&group_id=426&atid=1700

Also available as a Ruby Snippet:
http://rubyforge.org/snippet/detail.php?type=snippet&id=475

Public Domain - No Restrictions
=end


Files

ruby_const_update.rb (2.62 KB) ruby_const_update.rb RUBY Constant Update (v1.0.0) ruby_const_update.rb DanRathbun (Dan Rathbun), 08/07/2010 01:07 PM

History

#1

Updated by rkh (Konstantin Haase) almost 9 years ago

=begin

On Aug 7, 2010, at 06:07 , Dan Rathbun wrote:

RUBY_COPYRIGHT, RUBY_DESCRIPTION and
RUBY_PATCHLEVEL if less than ver 1.8.5-p12

Also, backporting RUBY_ENGINE to 1.8 would be helpful, imo.

Konstantin

=end

#2

Updated by DanRathbun (Dan Rathbun) almost 9 years ago

=begin
I checked v 1.8.7-p299 and RUBY_ENGINE is undefined.

Was this constant added in 1.9.0 ??

Currently the main if block will only run if RUBY_VERSION<'1.8.7'
=end

#3

Updated by shyouhei (Shyouhei Urabe) almost 9 years ago

  • Status changed from Open to Assigned

=begin

=end

#4

Updated by shyouhei (Shyouhei Urabe) over 2 years ago

  • Status changed from Assigned to Closed

Also available in: Atom PDF