Project

General

Profile

Backport #3367

make test failed with test_thread.rb

Added by fundawang (Funda Wang) over 9 years ago. Updated 3 months ago.

Status:
Closed
Priority:
Normal
[ruby-core:30521]

Description

=begin
$ make test

test_thread.rb .....................F........................

#326 test_thread.rb:191:in `':
begin
100.times do |i|
begin
Thread.start(Thread.current) {|u| u.raise }
raise
rescue
ensure
end
end
rescue
100
end
#=> "" (expected "100") [ruby-dev:31371]
FAIL 1/948 tests failed
make: *** [btest-ruby] Error 1

$ rpm -q glibc
glibc-2.11.1-6mnb2
$ gcc --version
gcc (GCC) 4.4.3
=end


Related issues

Is duplicate of Backport191 - Backport #2948: failing test - test_thread.rb in ruby 1.9.1 p378 on linux redhatClosedActions

History

#1

Updated by fundawang (Funda Wang) over 9 years ago

=begin
dup with #2948. backport required.
=end

#2

Updated by nobu (Nobuyoshi Nakada) over 9 years ago

  • Category changed from build to core
  • Status changed from Open to Assigned
  • Assignee set to yugui (Yuki Sonoda)

=begin

=end

#3

Updated by jeremyevans0 (Jeremy Evans) 3 months ago

  • Status changed from Assigned to Closed

Also available in: Atom PDF