Project

General

Profile

Bug #2960

svn revision detection of git-based repo on Windows is broken

Added by vvs (Vladimir Sizikov) over 10 years ago. Updated over 9 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
ruby -v:
ruby 1.9.2dev (2010-03-14) [i386-mingw32]
Backport:
[ruby-core:28651]

Description

=begin
This leads to situation when MRI built on Windows from git-based repo doesn't show the actual SVN revision: ruby 1.9.2dev (2010-03-14) [i386-mingw32]

This is a regression caused by recent changes in file2lastrev.rb file.

Attached is a small patch that fixes the problem for me on Windows. And I checked that it works on Linux as well.
=end


Files

0001-Fix-svn-revison-detection-of-git-based-repo-on-Windo.patch (799 Bytes) 0001-Fix-svn-revison-detection-of-git-based-repo-on-Windo.patch Small patch to resolve the problem. vvs (Vladimir Sizikov), 03/14/2010 07:35 PM

Also available in: Atom PDF