Project

General

Profile

Bug #193

Crash during build on Mac OS 10.5.3/PPC when configured with --enable-pthread

Added by febeling (Florian Ebeling) about 12 years ago. Updated over 9 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
ruby -v:
[ruby-core:17333]

Description

=begin
This is the output:

usr/bin/gcc-4.0 -O2 -fno-common -pipe -fno-common -DRUBY_EXPORT
-I. -I. -I/opt/local/include -D_XOPEN_SOURCE -D_DARWIN_C_SOURCE -c
./missing/alloca.c
./missing/alloca.c:144: warning: conflicting types for built-in
function 'alloca'
/usr/bin/gcc-4.0 -O2 -fno-common -pipe -fno-common -DRUBY_EXPORT
-I. -I. -I/opt/local/include -D_XOPEN_SOURCE -D_DARWIN_C_SOURCE -c
dmyext.c
ar rcu libruby-static.a array.o bignum.o class.o compar.o dir.o dln.o
enum.o enumerator.o error.o eval.o file.o gc.o hash.o inits.o io.o
marshal.o math.o numeric.o object.o pack.o parse.o process.o prec.o
random.o range.o re.o regex.o ruby.o signal.o sprintf.o st.o string.o
struct.o time.o util.o variable.o version.o alloca.o dmyext.o
/usr/bin/gcc-4.0 -O2 -fno-common -pipe -fno-common -DRUBY_EXPORT
-I. -I. -I/opt/local/include -D_XOPEN_SOURCE -D_DARWIN_C_SOURCE -c
main.c
/usr/bin/gcc-4.0 -O2 -fno-common -pipe -fno-common -DRUBY_EXPORT
-I. -I. -I/opt/local/include -D_XOPEN_SOURCE -D_DARWIN_C_SOURCE -c
dmydln.c
/usr/bin/gcc-4.0 -O2 -fno-common -pipe -fno-common -DRUBY_EXPORT
-L. -L/opt/local/lib main.o dmydln.o libruby-static.a -lpthread -ldl
-lobjc -o miniruby
./ext/purelib.rb:5: [BUG] Segmentation fault
ruby 1.8.7 (2008-06-09 patchlevel 17) [powerpc-darwin9.3.0]

Earlier during the build the following warnings appear (and they dont
appear on Mac 10.5.3/Intel):

gcc -g -O2 -pipe -fno-common -DRUBY_EXPORT -I. -I. -D_XOPEN_SOURCE -D_DARWIN_C_SOURCE -c range.c
gcc -g -O2 -pipe -fno-common -DRUBY_EXPORT -I. -I. -D_XOPEN_SOURCE -D_DARWIN_C_SOURCE -c re.c
gcc -g -O2 -pipe -fno-common -DRUBY_EXPORT -I. -I. -D_XOPEN_SOURCE -D_DARWIN_C_SOURCE -c regex.c
regex.c: In function 'ruby_re_compile_pattern':
regex.c:1355: warning: incompatible implicit declaration of built-in function 'alloca'
regex.c:1437: warning: incompatible implicit declaration of built-in function 'alloca'
regex.c:1473: warning: incompatible implicit declaration of built-in function 'alloca'
regex.c:1480: warning: incompatible implicit declaration of built-in function 'alloca'
regex.c:1492: warning: incompatible implicit declaration of built-in function 'alloca'

[Sorry, I couldn't figure out code formatting here.]
=end


Files

configure.diff (355 Bytes) configure.diff correct cpu-type "ppc" -> "powerpc" kimuraw (Wataru Kimura), 11/06/2008 02:17 AM
#1

Updated by febeling (Florian Ebeling) about 12 years ago

=begin
I think I didn't mention this was was patchlevel 17.
=end

#2

Updated by febeling (Florian Ebeling) about 12 years ago

=begin
This issue seems to be solved in p22, please close the bug.
=end

#3

Updated by shyouhei (Shyouhei Urabe) about 12 years ago

  • Status changed from Open to Closed
  • % Done changed from 0 to 100

=begin

=end

#4

Updated by kimuraw (Wataru Kimura) almost 12 years ago

=begin
I reproduce this problem on Mac OS X 10.5.3 with ruby-1.8.7-p72.
The attached patch will fix the problem.
=end

Also available in: Atom PDF