Project

General

Profile

Feature #14696

add optname SO_ORIGINAL_DST

Added by takafan (taka fan) about 1 year ago. Updated about 1 year ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Target version:
-
[ruby-core:86572]

Description

SO_ORIGINAL_DST is defined at
https://github.com/torvalds/linux/blob/master/include/uapi/linux/netfilter_ipv4.h

get original dst while accepting a socket from iptables target REDIRECT

i made a pull request at github:

https://github.com/ruby/ruby/pull/1859


Related issues

Is duplicate of Ruby trunk - Feature #6394: Support SO_ORIGINAL_DST socket optionRejectedActions

History

Updated by akr (Akira Tanaka) about 1 year ago

SO_ORIGINAL_DST is defined in linux kernel header, not glibc header.

The provided patch defines SO_ORIGINAL_DST as 80 in ext/socket/rubysocket.h.

There are several options:

  • define the constant in Ruby as the patch. This add (one) more magic number in Ruby
  • include linux kernel headers. It may conflict with glibc headers
  • define the constant in application as Socket::SO_ORIGINAL_DST = 80
#2

Updated by akr (Akira Tanaka) about 1 year ago

  • Related to Feature #6394: Support SO_ORIGINAL_DST socket option added
#3

Updated by nobu (Nobuyoshi Nakada) about 1 year ago

  • Is duplicate of Feature #6394: Support SO_ORIGINAL_DST socket option added
#4

Updated by nobu (Nobuyoshi Nakada) about 1 year ago

  • Related to deleted (Feature #6394: Support SO_ORIGINAL_DST socket option)

Updated by matz (Yukihiro Matsumoto) about 1 year ago

  • Status changed from Open to Rejected

I didn't know SO_ORIGINAL_DST is not defined in libc headers.
In this case, I'd suggest defining the constant in your application.

Matz.

Also available in: Atom PDF