Project

General

Profile

Bug #12392

configure --with-sitedir=no --with-sitearchdir=no --with-vendordir=no --with-vendorarchdir=no が機能しない

Added by yoko-a (Atsushi YOKOYAMA) almost 4 years ago. Updated 4 days ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
ruby -v:
ruby 2.3.1p112 (2016-04-26 revision 54768) [x86_64-linux]
[ruby-dev:49628]
Tags:

Description

configure のヘルプでは、オプション --with-sitedir, --with-sitearchdir, --with-vendordir, --with-vendorarchdir に noを与えられることになっているが、正しく機能しない。

make installでカレントディレクトリに誤ったディレクトリが生成される。
また、ライブラリ検索パスに誤ったエントリが残る。

% ./configure --with-sitedir=no --with-sitearchdir=no --with-vendordir=no --with-vendorarchdir=no
% make
% sudo make install
% ls -l | head -3
total 147396
drwxr-xr-x  3 root   root       4096 May 18 23:51 $(sitedir)/
drwxr-xr-x  3 root   root       4096 May 18 23:51 $(vendordir)/
%
% ruby -e 'puts $:.join("\n")'
/usr/local/lib/ruby/gems/2.3.0/gems/did_you_mean-1.0.0/lib
${sitedir}/2.3.0
${sitearchdir}
${sitedir}
${vendordir}/2.3.0
${vendorarchdir}
${vendordir}
/usr/local/lib/ruby/2.3.0
/usr/local/lib/ruby/2.3.0/x86_64-linux
%
#1

Updated by nobu (Nobuyoshi Nakada) 14 days ago

  • Status changed from Open to Closed

Applied in changeset git|8a6ba10f9dd456cf54de800203cf04bbe42271fb.


Do not make disabled directories at installation [Bug #12392]

#2

Updated by nobu (Nobuyoshi Nakada) 14 days ago

  • Backport changed from 2.1: UNKNOWN, 2.2: UNKNOWN, 2.3: UNKNOWN to 2.5: REQUIRED, 2.6: REQUIRED, 2.7: REQUIRED

Updated by nagachika (Tomoyuki Chikanaga) 12 days ago

  • Backport changed from 2.5: REQUIRED, 2.6: REQUIRED, 2.7: REQUIRED to 2.5: REQUIRED, 2.6: DONE, 2.7: REQUIRED

ruby_2_6 r67844 merged revision(s) 8a6ba10f9dd456cf54de800203cf04bbe42271fb.

Updated by naruse (Yui NARUSE) 4 days ago

  • Backport changed from 2.5: REQUIRED, 2.6: DONE, 2.7: REQUIRED to 2.5: REQUIRED, 2.6: DONE, 2.7: DONE

ruby_2_7 95c3bb6c426a11253644a86137bb67c542fd5799.

Also available in: Atom PDF