Project

General

Profile

Bug #12078

Segmentation fault in did_you_mean with ruby revision 53608

Added by reggiebatsky (Rob Nichols) over 4 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
[ruby-core:73843]

Description

A segmentation bug occurred when running rspec tests on an app. This first appeared using ruby 2.3.0p0 revision 53290, and appeared similar to bugs reported in issues https://bugs.ruby-lang.org/issues/12000 and https://bugs.ruby-lang.org/issues/11928. 11928 implies that the bug should have been fixed at revision 53524, so I have updated ruby to 2.3.0p7 revision 53608 and am still getting segmentation faults.

The error output starts with:

/Users/foo/.rvm/gems/ruby-2.3-head@global/gems/did_you_mean-1.0.0/lib/did_you_mean/spell_checkers/name_error_checkers/variable_name_checker.rb:10: [BUG] Segmentation fault at 0x00000000000011
ruby 2.3.0p7 (2016-01-21 revision 53608) [x86_64-darwin14]

and ends:

[NOTE]
You may have encountered a bug in the Ruby interpreter or extension libraries.
Bug reports are welcome.
For details: http://www.ruby-lang.org/bugreport.html

/Users/foo/.rvm/rubies/ruby-2.3-head/bin/ruby -I/Users/foo/.rvm/gems/ruby-2.3-head/gems/rspec-core-3.4.2/lib:/Users/foo/.rvm/gems/ruby-2.3-head/gems/rspec-support-3.4.1/lib /Users/foo/.rvm/gems/ruby-2.3-head/gems/rspec-core-3.4.2/exe/rspec --pattern spec/\*\*\{,/\*/\*\*\}/\*_spec.rb failed
rake aborted!
TypeError: no implicit conversion from nil to integer
/Users/foo/.rvm/gems/ruby-2.3-head/gems/rspec-core-3.4.2/lib/rspec/core/rake_task.rb:84:in `exit'
/Users/foo/.rvm/gems/ruby-2.3-head/gems/rspec-core-3.4.2/lib/rspec/core/rake_task.rb:84:in `run_task'
/Users/foo/.rvm/gems/ruby-2.3-head/gems/rspec-core-3.4.2/lib/rspec/core/rake_task.rb:96:in `block (2 levels) in define'
/Users/foo/.rvm/gems/ruby-2.3-head/gems/rspec-core-3.4.2/lib/rspec/core/rake_task.rb:94:in `block in define'
/Users/foo/.rvm/gems/ruby-2.3-head/bin/ruby_executable_hooks:15:in `eval'
/Users/foo/.rvm/gems/ruby-2.3-head/bin/ruby_executable_hooks:15:in `<main>'
Tasks: TOP => spec

Files

ruby_2016-02-16-093730_LEEML0195905.crash (23.9 KB) ruby_2016-02-16-093730_LEEML0195905.crash Original crash reggiebatsky (Rob Nichols), 02/16/2016 11:36 AM
ruby_2016-02-16-100949_LEEML0195905.crash (24.1 KB) ruby_2016-02-16-100949_LEEML0195905.crash Crash after updating to revision 53608 reggiebatsky (Rob Nichols), 02/16/2016 11:36 AM

Related issues

Is duplicate of Ruby master - Bug #11928: Segmentation fault in did_you_mean extensionClosedActions
#1

Updated by nobu (Nobuyoshi Nakada) over 4 years ago

  • Is duplicate of Bug #11928: Segmentation fault in did_you_mean extension added

Updated by nobu (Nobuyoshi Nakada) over 4 years ago

  • Status changed from Open to Closed
  • Backport changed from 2.0.0: UNKNOWN, 2.1: UNKNOWN, 2.2: UNKNOWN, 2.3: UNKNOWN to 2.0.0: DONTNEED, 2.1: DONTNEED, 2.2: DONTNEED, 2.3: REQUIRED

Updated by sawa (Tsuyoshi Sawada) over 4 years ago

I also got a similar bug with Ruby 2.3.0p7 revision 53608. As the poster writes, this version is later than revision 53524, in which a similar (alleged duplicate) bug has been supposed to be fixed. But the bug retains, and the present issue is closed. Am I missing something? Is there a version available that does not have such bug?

Updated by nobu (Nobuyoshi Nakada) over 4 years ago

r53524 is the revision in the trunk, not 2.3.
And #11928's backport status to 2.3 is still REQUIRED.

Updated by naruse (Yui NARUSE) over 4 years ago

  • Backport changed from 2.0.0: DONTNEED, 2.1: DONTNEED, 2.2: DONTNEED, 2.3: REQUIRED to 2.0.0: DONTNEED, 2.1: DONTNEED, 2.2: DONTNEED, 2.3: DONTNEED

Also available in: Atom PDF