Project

General

Profile

Feature #11398

deprecate constants

Added by nobu (Nobuyoshi Nakada) over 5 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
[ruby-core:70142]

Description

Sometimes old constants are deprecated but still remained for backward compatibilities.
It is not noticed and will be kept forever, with no warnings, though.
So I propose a method Module#deprecate_constant to mark a constant obsolete and emit a warning message when it is referred.

https://github.com/nobu/ruby/tree/Module%23deprecate_constant


Related issues

Is duplicate of Ruby master - Feature #10342: Module#deprecate_constantClosedmatz (Yukihiro Matsumoto)Actions

Also available in: Atom PDF