Project

General

Profile

Bug #10839

OpenSSL 1.0.2 does not allow wrap mode (fixed by r49525)

Added by nagachika (Tomoyuki Chikanaga) almost 5 years ago. Updated almost 5 years ago.

Status:
Closed
Priority:
Normal
Target version:
-
[ruby-dev:48858]

Description

バックポート管理用です。

r49525 の修正が RubyCI の Yosemite での 1F をなおしてくれそうです。


Related issues

Is duplicate of Ruby master - Bug #10229: RFC 5649 implementation in OpenSSL breaks Ruby.Closed09/11/2014Actions

Associated revisions

Revision 095d964e
Added by nagachika (Tomoyuki Chikanaga) almost 5 years ago

merge revision(s) r49525: [Backport #10839]

    test_cipher.rb: OpenSSL 1.0.2

    * test/openssl/test_cipher.rb (OpenSSL::TestCipher#test_ciphers):

OpenSSL 1.0.2 does not allow wrap mode.

git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/branches/ruby_2_1@49548 b2dd03c8-39d4-4d8f-98ff-823fe69b080e

Revision 49548
Added by nagachika (Tomoyuki Chikanaga) almost 5 years ago

merge revision(s) r49525: [Backport #10839]

test_cipher.rb: OpenSSL 1.0.2

* test/openssl/test_cipher.rb (OpenSSL::TestCipher#test_ciphers):

OpenSSL 1.0.2 does not allow wrap mode.

Revision c85e4fce
Added by naruse (Yui NARUSE) almost 5 years ago

merge revision(s) 49525,49575: [Backport #10839]

    test_cipher.rb: OpenSSL 1.0.2

    * test/openssl/test_cipher.rb (OpenSSL::TestCipher#test_ciphers):

OpenSSL 1.0.2 does not allow wrap mode.

git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/branches/ruby_2_2@49584 b2dd03c8-39d4-4d8f-98ff-823fe69b080e

Revision 49584
Added by naruse (Yui NARUSE) almost 5 years ago

merge revision(s) 49525,49575: [Backport #10839]

test_cipher.rb: OpenSSL 1.0.2

* test/openssl/test_cipher.rb (OpenSSL::TestCipher#test_ciphers):

OpenSSL 1.0.2 does not allow wrap mode.

Revision 40705c2b
Added by nagachika (Tomoyuki Chikanaga) almost 5 years ago

merge revision(s) r49575,r49579: [Backport #10839]

    test_cipher.rb: show cipher name

    * test/openssl/test_cipher.rb (test_ciphers): show wrap mode

cipher name, which does not end with "wrap".
http://rubyci.blob.core.windows.net/fedora21/ruby-trunk/log/20150212T061502Z.fail.html.gz

git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/branches/ruby_2_1@49588 b2dd03c8-39d4-4d8f-98ff-823fe69b080e

Revision 49588
Added by nagachika (Tomoyuki Chikanaga) almost 5 years ago

merge revision(s) r49575,r49579: [Backport #10839]

test_cipher.rb: show cipher name

* test/openssl/test_cipher.rb (test_ciphers): show wrap mode

cipher name, which does not end with "wrap".
http://rubyci.blob.core.windows.net/fedora21/ruby-trunk/log/20150212T061502Z.fail.html.gz

Revision 61bb4b38
Added by usa (Usaku NAKAMURA) almost 5 years ago

merge revision(s) 49525,49575,49579: [Backport #10839]

    test_cipher.rb: OpenSSL 1.0.2

    * test/openssl/test_cipher.rb (OpenSSL::TestCipher#test_ciphers):

OpenSSL 1.0.2 does not allow wrap mode.

git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/branches/ruby_2_0_0@49626 b2dd03c8-39d4-4d8f-98ff-823fe69b080e

Revision 49626
Added by usa (Usaku NAKAMURA) almost 5 years ago

merge revision(s) 49525,49575,49579: [Backport #10839]

test_cipher.rb: OpenSSL 1.0.2

* test/openssl/test_cipher.rb (OpenSSL::TestCipher#test_ciphers):

OpenSSL 1.0.2 does not allow wrap mode.

Revision 64e6d2bd
Added by naruse (Yui NARUSE) almost 5 years ago

merge revision(s) 49579: [Backport #10839]

    test_cipher.rb: ignore wrap mode erros

    * test/openssl/test_cipher.rb (test_ciphers): ignore wrap mode

errors if "wrap" is contained in the name. seems no explicit
rules.
http://rubyci.blob.core.windows.net/fedora21/ruby-trunk/log/20150213T001502Z.fail.html.gz

git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/branches/ruby_2_2@49636 b2dd03c8-39d4-4d8f-98ff-823fe69b080e

Revision 49636
Added by naruse (Yui NARUSE) almost 5 years ago

merge revision(s) 49579: [Backport #10839]

test_cipher.rb: ignore wrap mode erros

* test/openssl/test_cipher.rb (test_ciphers): ignore wrap mode

errors if "wrap" is contained in the name. seems no explicit
rules.
http://rubyci.blob.core.windows.net/fedora21/ruby-trunk/log/20150213T001502Z.fail.html.gz

History

Updated by nagachika (Tomoyuki Chikanaga) almost 5 years ago

  • Backport changed from 2.0.0: REQUIRED, 2.1: REQUIRED, 2.2: REQUIRED to 2.0.0: REQUIRED, 2.1: DONE, 2.2: REQUIRED

Backported into ruby_2_1 at r49548.

Updated by nagachika (Tomoyuki Chikanaga) almost 5 years ago

r49575 で fedora での失敗の調査(?)のため追加修正あり。

Updated by naruse (Yui NARUSE) almost 5 years ago

  • Backport changed from 2.0.0: REQUIRED, 2.1: DONE, 2.2: REQUIRED to 2.0.0: REQUIRED, 2.1: DONE, 2.2: DONE

ruby_2_2 r49584 merged revision(s) 49525,49575.

Updated by nagachika (Tomoyuki Chikanaga) almost 5 years ago

  • Backport changed from 2.0.0: REQUIRED, 2.1: DONE, 2.2: DONE to 2.0.0: REQUIRED, 2.1: REQUIRED, 2.2: REQUIRED

r49579 で Fedora21 での CI も対応した模様。
Backport の DONE を外しておきます。

Updated by nagachika (Tomoyuki Chikanaga) almost 5 years ago

  • Backport changed from 2.0.0: REQUIRED, 2.1: REQUIRED, 2.2: REQUIRED to 2.0.0: REQUIRED, 2.1: DONE, 2.2: REQUIRED

r49575 and r49579 were merged into ruby_2_1 branch at r49588.

Updated by usa (Usaku NAKAMURA) almost 5 years ago

  • Backport changed from 2.0.0: REQUIRED, 2.1: DONE, 2.2: REQUIRED to 2.0.0: DONE, 2.1: DONE, 2.2: REQUIRED

ruby_2_0_0 r49626 merged revision(s) 49525,49575,49579.

Updated by naruse (Yui NARUSE) almost 5 years ago

  • Backport changed from 2.0.0: DONE, 2.1: DONE, 2.2: REQUIRED to 2.0.0: DONE, 2.1: DONE, 2.2: DONE

ruby_2_2 r49636 merged revision(s) 49579.

#8

Updated by vo.x (Vit Ondruch) almost 5 years ago

  • Is duplicate of Bug #10229: RFC 5649 implementation in OpenSSL breaks Ruby. added

Also available in: Atom PDF