Project

General

Profile

Bug #8880

Refinements bug in ruby 2.1.0dev (2013-09-08) [x86_64-linux]

Added by minad (Daniel Mendler) about 7 years ago. Updated about 7 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
ruby -v:
ruby 2.1.0dev (2013-09-08) [x86_64-linux]
[ruby-core:57079]

Description

Hi,

I found a bug in the refinements implementation of Ruby 2.1.0. It is related to https://bugs.ruby-lang.org/issues/8722. On ruby 2.0.0p0 (2013-02-24 revision 39474) this does not occur.

The VM segfaults when the attached code is executed. The problem is that a used refinement is modified afterwards.

Daniel


Files

broken.rb (179 Bytes) broken.rb minad (Daniel Mendler), 09/09/2013 10:13 AM

Also available in: Atom PDF