Project

General

Profile

Actions

Feature #7907

closed

Give meaning to staby word

Added by trans (Thomas Sawyer) almost 10 years ago. Updated almost 10 years ago.

Status:
Rejected
Priority:
Normal
Target version:
[ruby-core:52630]

Description

=begin
I noticed that ->word doesn't mean anything. i.e.

->foo
SyntaxError: (irb):4: syntax error, unexpected '\n', expecting keyword_do_LAMBDA or tLAMBEG
from /opt/Ruby/1.9.3-p327/bin/irb:12:in `'

If that is always so, then could it be given a meaning as a shorthand for method()? i.e.

->foo

would be the same as writing

method(:foo).to_proc

=end


Related issues 1 (0 open1 closed)

Is duplicate of Ruby master - Feature #7906: Giving meaning to ->foo Rejectedmatz (Yukihiro Matsumoto)02/22/2013Actions

Updated by ko1 (Koichi Sasada) almost 10 years ago

  • Description updated (diff)
  • Assignee set to matz (Yukihiro Matsumoto)

Updated by matz (Yukihiro Matsumoto) almost 10 years ago

  • Status changed from Open to Rejected

=begin
I think filling the syntax hole eagerly is a bad idea.

Besides that, I don't think making ((%->foo%)) as method(:foo).to_proc seems a good idea,
since foo in ((%->foo{}%)) is a argument name, not a method name.

Matz.
=end

Updated by trans (Thomas Sawyer) almost 10 years ago

Ah, ->foo{} did not know that the parenthesis could be left out.

Ok, I'll suggest slight modification then, b/c it still would be nice to have a shorter notation (not just to fill a syntax hole). Could it be a symbol, i.e. ->:foo.

Updated by trans (Thomas Sawyer) almost 10 years ago

Once a issue has been rejected, is it necessary to open a new case for a modified form of the proposal? In other words is any one going to see the change if it has already been rejected? As with this case?

Updated by rosenfeld (Rodrigo Rosenfeld Rosas) almost 10 years ago

People will see the changes but when they're looking for open issues to decide what to do about them they won't touch closed issues :)

Actions

Also available in: Atom PDF

Like0
Like0Like0Like0Like0Like0