Project

General

Profile

Actions

Backport #6681

closed

migw32 で utf-8 のスクリプトで「版」で終わるディレクトリの File.basename

Added by taki (Tatsuo Akiyama) about 10 years ago. Updated almost 10 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
[ruby-dev:45887]

Description

=begin

migw32 で utf-8 のスクリプトで「版」で終わるディレクトリの File.basename の結果がおかしいです。

スクリプト test1.rb

-- coding: utf-8 --

puts File.basename("1版/memo1.txt")

スクリプト test2.rb

-- coding: Shift_JIS --

puts File.basename("1版/memo1.txt")

どちらも「memo1.txt」が表示されることを期待しましたが、test1.rb だと「1版/memo1.txt」が表示されます。

ruby -v
ruby 1.9.3p194 (2012-04-20) [i386-mingw32]

ruby test1.rb
1版/memo1.txt

ruby test2.rb
memo1.txt

rubyinstaller.org 配布のバイナリを利用しています。

=end


Related issues 1 (0 open1 closed)

Is duplicate of Ruby master - Bug #5919: File singleton methods (expand_path, realpath, dirname, basename, extname) should respect encodingsClosednaruse (Yui NARUSE)01/21/2012Actions
Actions

Also available in: Atom PDF