Project

General

Profile

Bug #6506

configure --disable-install-doc していると make install で ruby がビルドされない

Added by nagachika (Tomoyuki Chikanaga) about 8 years ago. Updated about 8 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
ruby -v:
ruby 2.0.0dev (2012-05-19 trunk 35721) [x86_64-darwin10.8.0]
Backport:
[ruby-dev:45683]

Description

configure --disable-install-doc を指定していると、make install しても
miniruby だけ再ビルドされて ruby は古いままで install されるようです。
make clean した状態から make install してもやっぱり ruby が作成されないのでエラーになります。

以下のパッチで一応 make install は成功する(再ビルドされる)ようになりました。

diff --git a/common.mk b/common.mk
index 94da381..bce7801 100644
--- a/common.mk
+++ b/common.mk
@@ -240,7 +240,7 @@ post-install-all:: post-install-local post-install-ext post-install-doc

install-nodoc: pre-install-nodoc do-install-nodoc post-install-nodoc
pre-install-nodoc:: pre-install-local pre-install-ext
-do-install-nodoc: $(PREP)
+do-install-nodoc: $(PROGRAM) $(PREP)
$(INSTRUBY) --make="$(MAKE)" $(INSTRUBY_ARGS)
post-install-nodoc:: post-install-local post-install-ext

#1

Updated by nobu (Nobuyoshi Nakada) about 8 years ago

  • Status changed from Open to Closed
  • % Done changed from 0 to 100

This issue was solved with changeset r35829.
Tomoyuki, thank you for reporting this issue.
Your contribution to Ruby is greatly appreciated.
May Ruby be with you.


common.mk: fix dependencies.

  • common.mk (do-install-*): fix dependencies. based on the patch by nagachika at [ruby-dev:45683]. [Bug #6506]

Also available in: Atom PDF