Project

General

Profile

Actions

Bug #5340

closed

mysql2.bundle: [BUG] Segmentation fault

Added by daBee (da Bee) almost 11 years ago. Updated over 9 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Target version:
-
ruby -v:
ruby 1.9.2p290 (2011-07-09 revision 32553) [x86_64-darwin10.8.0]
Backport:
[ruby-core:39626]

Description

HQ:simple_cms rich$ rails g controller demo index
/Users/rich/.rvm/gems/ruby-1.9.2-p290/gems/mysql2-0.3.7/lib/mysql2/mysql2.bundle: [BUG] Segmentation fault
ruby 1.9.2p290 (2011-07-09 revision 32553) [x86_64-darwin10.8.0]

-- control frame ----------
c:0022 p:-542184014 s:0065 b:0065 l:000064 d:000064 TOP
c:0021 p:---- s:0063 b:0063 l:000062 d:000062 CFUNC :require
c:0020 p:0119 s:0059 b:0059 l:000058 d:000058 TOP /Users/rich/.rvm/gems/ruby-1.9.2-p290/gems/mysql2-0.3.7/lib/mysql2.rb:9
c:0019 p:---- s:0057 b:0057 l:000056 d:000056 FINISH
c:0018 p:---- s:0055 b:0055 l:000054 d:000054 CFUNC :require
c:0017 p:0026 s:0051 b:0051 l:000032 d:000050 BLOCK /Users/rich/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/runtime.rb:68
c:0016 p:---- s:0048 b:0048 l:000047 d:000047 FINISH
c:0015 p:---- s:0046 b:0046 l:000045 d:000045 CFUNC :each
c:0014 p:0091 s:0043 b:0043 l:000032 d:000042 BLOCK /Users/rich/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/runtime.rb:66
c:0013 p:---- s:0038 b:0038 l:000037 d:000037 FINISH
c:0012 p:---- s:0036 b:0036 l:000035 d:000035 CFUNC :each
c:0011 p:0046 s:0033 b:0033 l:000032 d:000032 METHOD /Users/rich/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/runtime.rb:55
c:0010 p:0021 s:0029 b:0029 l:000028 d:000028 METHOD /Users/rich/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler.rb:120
c:0009 p:0089 s:0025 b:0025 l:000024 d:000024 TOP /Library/WebServer/Documents/simple_cms/config/application.rb:7
c:0008 p:---- s:0023 b:0023 l:000022 d:000022 FINISH
c:0007 p:---- s:0021 b:0021 l:000020 d:000020 CFUNC :require
c:0006 p:0377 s:0017 b:0017 l:000016 d:000016 TOP /Users/rich/.rvm/gems/ruby-1.9.2-p290/gems/railties-3.1.0/lib/rails/commands.rb:21
c:0005 p:---- s:0012 b:0012 l:000011 d:000011 FINISH
c:0004 p:---- s:0010 b:0010 l:000009 d:000009 CFUNC :require
c:0003 p:0061 s:0006 b:0006 l:0014e8 d:000278 EVAL script/rails:6
c:0002 p:---- s:0004 b:0004 l:000003 d:000003 FINISH
c:0001 p:0000 s:0002 b:0002 l:0014e8 d:0014e8 TOP

-- Ruby level backtrace information ----------------------------------------
script/rails:6:in <main>' script/rails:6:in require'
/Users/rich/.rvm/gems/ruby-1.9.2-p290/gems/railties-3.1.0/lib/rails/commands.rb:21:in <top (required)>' /Users/rich/.rvm/gems/ruby-1.9.2-p290/gems/railties-3.1.0/lib/rails/commands.rb:21:in require'
/Library/WebServer/Documents/simple_cms/config/application.rb:7:in <top (required)>' /Users/rich/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler.rb:120:in require'
/Users/rich/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/runtime.rb:55:in require' /Users/rich/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/runtime.rb:55:in each'
/Users/rich/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/runtime.rb:66:in block in require' /Users/rich/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/runtime.rb:66:in each'
/Users/rich/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/runtime.rb:68:in block (2 levels) in require' /Users/rich/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/runtime.rb:68:in require'
/Users/rich/.rvm/gems/ruby-1.9.2-p290/gems/mysql2-0.3.7/lib/mysql2.rb:9:in <top (required)>' /Users/rich/.rvm/gems/ruby-1.9.2-p290/gems/mysql2-0.3.7/lib/mysql2.rb:9:in require'

-- C level backtrace information -------------------------------------------

[NOTE]
You may have encountered a bug in the Ruby interpreter or extension libraries.
Bug reports are welcome.
For details: http://www.ruby-lang.org/bugreport.html

Abort trap
HQ:simple_cms rich$ ruby -v
ruby 1.9.2p290 (2011-07-09 revision 32553) [x86_64-darwin10.8.0]
HQ:simple_cms rich$ rvm -v

rvm 1.8.3 by Wayne E. Seguin () [https://rvm.beginrescueend.com/]

Server version: 5.5.16 MySQL Community Server (GPL)

Updated by normalperson (Eric Wong) almost 11 years ago

da Bee wrote:

HQ:simple_cms rich$ rails g controller demo index
/Users/rich/.rvm/gems/ruby-1.9.2-p290/gems/mysql2-0.3.7/lib/mysql2/mysql2.bundle: [BUG] Segmentation fault
ruby 1.9.2p290 (2011-07-09 revision 32553) [x86_64-darwin10.8.0]

-- control frame ----------
c:0022 p:-542184014 s:0065 b:0065 l:000064 d:000064 TOP
c:0021 p:---- s:0063 b:0063 l:000062 d:000062 CFUNC :require

I cannot reproduce this on Linux x86_64 with mysql2 0.3.7 and rails 3.1.0.

Can you check if the MySQL client library used by mysql2 is linked to
OpenSSL, and if so, is it linked to the same version/installation
of OpenSSL as the Ruby "openssl" extension?

On GNU/Linux, this would be done with the ldd command on the ".so"
files, but you might have different-but-equivalent commands on
Darwin/OSX.

Actions #2

Updated by ayumin (Ayumu AIZAWA) almost 11 years ago

  • Status changed from Open to Feedback

Updated by mame (Yusuke Endoh) over 9 years ago

  • Status changed from Feedback to Rejected

Sorry, but I'm closing this ticket because it is too clueless and OP did not answer.
Please tell us if you can repro.

--
Yusuke Endoh

Actions

Also available in: Atom PDF