Bug #4738

gem install fails with "Encoding::ConverterNotFoundError" on windows 7 greek

Added by Lazaridis Ilias over 4 years ago. Updated over 3 years ago.

[ruby-core:36329]
Status:Closed
Priority:Normal
Assignee:-
ruby -v:ruby 1.9.2p180 (2011-02-18) [i386-mingw32] Backport:

Description

On windows 7 greek.

Installer used:
http://rubyforge.org/frs/download.php/74298/rubyinstaller-1.9.2-p180.exe

P:>cmd
Microsoft Windows [Έκδοση 6.1.7600]
Πνευματικά δικαιώματα (c) 2009 Microsoft Corporation. Με επιφύλαξη κάθε νόμιμου δικαιώματος.

P:>ruby -v
ruby 1.9.2p180 (2011-02-18) [i386-mingw32]

P:>gem -v
1.5.2

P:>gem install json_pure
ERROR: While executing gem ... (Encoding::ConverterNotFoundError)
code converter not found (UTF-16LE to IBM737)

P:>gem install json_pure --debug -V
Exception NameError' at P:/prg/ruby192/lib/ruby/site_ruby/1.9.1/rubygems/command_manager.rb:163 - uninitialized constant Gem::Commands::InstallCommand
Exception
Encoding::ConverterNotFoundError' at P:/prg/ruby192/lib/ruby/site_ruby/1.9.1/rubygems/dependency_installer.rb:195 - code converter not found (UTF-16LE to IBM737)
ERROR: While executing gem ... (Encoding::ConverterNotFoundError)
code converter not found (UTF-16LE to IBM737)
P:/prg/ruby192/lib/ruby/site_ruby/1.9.1/rubygems/dependency_installer.rb:195:in []'
P:/prg/ruby192/lib/ruby/site_ruby/1.9.1/rubygems/dependency_installer.rb:195:in
find_spec_by_name_and_version'
P:/prg/ruby192/lib/ruby/site_ruby/1.9.1/rubygems/dependency_installer.rb:244:in install'
P:/prg/ruby192/lib/ruby/site_ruby/1.9.1/rubygems/commands/install_command.rb:120:in
block in execute'
P:/prg/ruby192/lib/ruby/site_ruby/1.9.1/rubygems/commands/install_command.rb:115:in each'
P:/prg/ruby192/lib/ruby/site_ruby/1.9.1/rubygems/commands/install_command.rb:115:in
execute'
P:/prg/ruby192/lib/ruby/site_ruby/1.9.1/rubygems/command.rb:278:in invoke'
P:/prg/ruby192/lib/ruby/site_ruby/1.9.1/rubygems/command_manager.rb:133:in
process_args'
P:/prg/ruby192/lib/ruby/site_ruby/1.9.1/rubygems/command_manager.rb:103:in run'
P:/prg/ruby192/lib/ruby/site_ruby/1.9.1/rubygems/gem_runner.rb:63:in
run'
P:/prg/ruby192/bin/gem:21:in `'

Associated revisions

Revision 31644
Added by Nobuyoshi Nakada over 4 years ago

  • enc/trans/ibm737-tbl.rb: greek code page. fixes #4738

Revision 31644
Added by Nobuyoshi Nakada over 4 years ago

  • enc/trans/ibm737-tbl.rb: greek code page. fixes #4738

History

#1 Updated by Luis Lavena over 4 years ago

  • Status changed from Open to Feedback
  • Priority changed from 5 to Normal

Hello,

Please provide the complete output of "gem env" so we can determine which path option is generating these issues.

Also, will be great if you try this against latest version of Ruby (trunk) since lost of encoding issues has been solved. (This seems related to Dir.glob which has been solved in 1.9.3 - trunk)

If you don't know how to build from scratch, take a look to RubyInstaller codebase and use it to build your local copy:

https://github.com/oneclick/rubyinstaller

#2 Updated by Lazaridis Ilias over 4 years ago

Edit: deleted by myself, as not relevant to the issue.

#3 Updated by Luis Lavena over 4 years ago

Ilias Lazaridis wrote:

I'm sorry, I cannot go into this.

Sorry to hear that.

What I can do:

  • I could download and install, if you provide a download location.

Can't provide a binary for a non-released version. That is RubyInstaller policy to avoid confusion with stable releases.

  • Or I could apply and test a patch if one is provided.

Most likely the patches will be against Ruby C sourcecode, so is pointless you can't build yourself.

If you can't try against the trunk codebase then there is no way for us to reproduce this issue.

I believe issues associated with directory globing are already fixed in trunk and backported to 1.9.2 branch.

Instructions on how to do that are in RubyInstaller codebase.

#4 Updated by Lazaridis Ilias over 4 years ago

Edit: deleted by myself, as not relevant to the issue.

#5 Updated by Luis Lavena over 4 years ago

Ilias Lazaridis wrote:

(I'll come back to this issue in a few weeks/months, when I have setup local compilation of the ruby sources on my windows machine.)

Months? RubyInstaller codebase provides you the building blocks, you don't need to setup a development environment, it does for you and is self contained.

#6 Updated by Lazaridis Ilias over 4 years ago

Edit: deleted by myself, as not relevant to the issue.

#7 Updated by Nobuyoshi Nakada over 4 years ago

  • Status changed from Feedback to Closed
  • % Done changed from 0 to 100

This issue was solved with changeset r31644.
Ilias, thank you for reporting this issue.
Your contribution to Ruby is greatly appreciated.
May Ruby be with you.


  • enc/trans/ibm737-tbl.rb: greek code page. fixes #4738

#8 Updated by Lazaridis Ilias about 4 years ago

=begin

follow-up issue: #4774

=end

#9 Updated by Lazaridis Ilias over 3 years ago

Note to users which hit on this problem:

Please ignore the comments of "Luis Lavena", they have no relevance to the issue.

To solve the issue on your side, just install a ruby version >= 1.9.3-p0, which has this issue solved.

http://rubyinstaller.org/downloads/

If you use rails-installer, check the ruby version (ruby -v). If it's not >= 1.9.3-p0, then try to update it via the above rubyinstaller.

Alternatively, use a rails-installer which has 1.9.3-p0 by default, e.g.:

http://railsftw.bryanbibat.net/

#10 Updated by Martin Bosslet over 3 years ago

Lazaridis Ilias wrote:

Note to users which hit on this problem:

Please ignore the comments of "Luis Lavena", they have no relevance to the issue.

Hahaha, that just made my day! You, my friend, are really a master in the art of
trolling ;) That's like saying "Plaease ignore what matz has to say about Ruby. He
may have invented it, sure, but he doesn't know what he's talking about".

#11 Updated by Lazaridis Ilias over 3 years ago

Mr. Bosslet, you are the only person which is trolling here, because of your off-topic comment. Remember: you're commenting on a issue-tracking-system, which should strictly focus on the issue at hand.

I've validly updated the information (within the issue I had filed months ago), after I was contacted by a user who was confused and didn't know how to finally solve the issue (in context of a rails installation on a greek windows machine). There's no need to add further misleading off-topic comments.

As for Mr. Matsumoto: He's not the first designer (Ruby is not an invention, it's a design) who get's lost in the complexity he has created, trying to implement the (partially contrary) requirements he's specified. That's nothing special - except for dumb religious language fanatics of your kind, who think that language designers are gods.

Also available in: Atom PDF