Project

General

Profile

Bug #457

Is irb/xmp supported in 1.9?

Added by pragdave (Dave Thomas) almost 12 years ago. Updated about 9 years ago.

Status:
Closed
Priority:
Normal
ruby -v:
Backport:
[ruby-core:18347]

Description

=begin
Running the following:

require 'irb/xmp'

xmp <<END
artist = "Doc Severinsen"
artist.upcase
END

results in

(eval):3:in Raise': frame underflow (IRB::Frame::FrameUnderflow)
from /usr/local/rubybook/lib/ruby/1.9.0/irb/frame.rb:38:in
top'
from /usr/local/rubybook/lib/ruby/1.9.0/irb/frame.rb:54:in top'
from /usr/local/rubybook/lib/ruby/1.9.0/irb/xmp.rb:81:in
xmp'
from t1.rb:3:in `'
=end

Also available in: Atom PDF