Project

General

Profile

Bug #4336

test_require.rb#test_require_path_home が test failure

Added by kosaki (Motohiro KOSAKI) over 9 years ago. Updated over 9 years ago.

Status:
Closed
Priority:
Normal
Target version:
ruby -v:
ruby 1.9.3dev (2011-01-28 trunk 30697) [x86_64-linux]
Backport:
[ruby-dev:43134]

Description

=begin
r30660でエラー時のメッセージがfprintfからrb_warningにかわったので、(つまり無引数の時にはエラーが出なくなったので)
テストが失敗します。
テストを追従させるつもりでいますが、r30660のrevertのほうが好ましいという人がいたら教えてください。

3) Failure:
test_require_path_home(TestRequire) [/home/kosaki/linux/ruby-svn/ruby/test/ruby/test_require.rb:55]:
Expected /pathname too long (ignored).*(LoadError)/m to match "/home/kosaki/linux/ruby-svn/ruby/ruby: No such file or directory -- test_ruby_test_require (LoadError)\n".
=end


Related issues

Is duplicate of Ruby master - Bug #4334: r30660 以降 ruby/test_require.rb で 2FClosednobu (Nobuyoshi Nakada)01/28/2011Actions

Also available in: Atom PDF