Project

General

Profile

Backport #4150

Epic YAML Failure

Added by rawdod (David Richards) about 9 years ago. Updated 4 months ago.

Status:
Closed
Priority:
Normal
Assignee:
-
[ruby-core:33680]

Description

=begin
I just lost 14 hours of my life to this problem. I thought I perhaps had some deep misunderstanding of the whole system I was trying to build, but alas it was a bug.

I was serializing all my classes to yaml for storing the state to disk.. and I thought that that was a fairly perfect system.

But I was having failures in my program and I finally traced it down to an instance variable getting lost between the save yaml to disk and load it back parts.

I added a single instance variable to my class and also It did not matter if what the name of it was, and everything worked again.

I don't know if anyone cares about ruby 1.8.7 anymore or if the code in 1.9 for yaml has the same problems.

If someone cares enough to respond to me from this bug post I'll do what I can to help.

Needless to say this has made me feel very happy that 99% of the time I store data in databases and not in serialized objects.
=end

History

#1

Updated by rawdod (David Richards) about 9 years ago

=begin
ps. this is my ruby version: ruby 1.8.7 (2010-06-23 patchlevel 299) [x86_64-linux]
=end

#2

Updated by tenderlovemaking (Aaron Patterson) about 9 years ago

=begin
We need more information than your Ruby version to track down and fix a bug like this. :-)

Could you possibly provide a code sample? Then tell us what you expect the code sample to do, and describe what the code sample actually does?

Thanks.
=end

#3

Updated by jeremyevans0 (Jeremy Evans) 4 months ago

  • Status changed from Open to Closed
  • Description updated (diff)

Also available in: Atom PDF