Project

General

Profile

Backport #4064

Bundled gem doesn't work on Windows in Ruby 1.8.7 p302

Added by koppernickus (Adam Czepil) almost 9 years ago. Updated over 8 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
[ruby-core:33233]

Description

=begin
Below scenario works fine with ruby 1.9.2 but not with 1.8.7.

Scenario:

  1. I install ruby using Windows Installer rubyinstaller-1.8.7-p302.exe
  2. Installed version is: ruby 1.8.7 (2010-08-16 patchlevel 302) [i386-mingw32]
  3. I install some gem using gem.bat from bin directory
  4. In irb I require the gem
  5. Require fails as on below console output

I tried with other gems too.

== CONSOLE OUTPUT ==

C:\Programs\ruby-1.8.7\bin>gem.bat list

*** LOCAL GEMS ***

C:\Programs\ruby-1.8.7\bin>gem.bat install httpclient
Successfully installed httpclient-2.1.5.2
1 gem installed
Installing ri documentation for httpclient-2.1.5.2...
Installing RDoc documentation for httpclient-2.1.5.2...

C:\Programs\ruby-1.8.7\bin>gem.bat list

*** LOCAL GEMS ***

httpclient (2.1.5.2)

C:\Programs\ruby-1.8.7\bin>irb
irb(main):001:0> require "httpclient"
LoadError: no such file to load -- httpclient
from (irb):1:in `require'
from (irb):1
irb(main):002:0>
=end

History

#1

Updated by shyouhei (Shyouhei Urabe) almost 9 years ago

  • Status changed from Open to Rejected

=begin
Intended. RubyGems integration is a 1.9 feature.
=end

#2

Updated by koppernickus (Adam Czepil) almost 9 years ago

=begin
My mistake. One has to use require 'rubygems' in non-rails app in Ruby < 1.9 in order to be able to use any gem.
=end

Also available in: Atom PDF