Project

General

Profile

Bug #3105

seg faults and bus errors with ruby 1.8.7 p249

Added by rtmd30 (Greg Ferguson) over 9 years ago. Updated 4 months ago.

Status:
Closed
Priority:
Normal
Assignee:
-
ruby -v:
ruby 1.8.7 (2010-01-10 patchlevel 249) [i686-darwin9.8.0]
[ruby-core:29295]

Description

=begin
I am seeing a lot of segmentation faults and bus errors when running

 gem rdoc --all --overwrite

with my rvm installed ruby 1.8.7 p249 instance.

Ruby is reporting these errors repeatedly:

/Users/greg/.rvm/gems/ruby-1.8.7-p249/gems/rdoc-2.5/lib/rdoc/ri/store.rb:121: [BUG] Segmentation fault
/Users/greg/.rvm/gems/ruby-1.8.7-p249/gems/rdoc-2.5/lib/rdoc/ri/store.rb:224: [BUG] Segmentation fault
/Users/greg/.rvm/gems/ruby-1.8.7-p249/gems/rdoc-2.5/lib/rdoc/ri/store.rb:243: [BUG] Bus Error

All three errors appear to be in Marshal.

Here's the shell script I ran to get the attached output log.

#!/bin/sh
for i in gem list | awk '{print $1}' | sort
do
gem rdoc --overwrite $i
done

Let me know if there is anything else you need to know.
=end


Files

rebuild_ri.out (82.5 KB) rebuild_ri.out rtmd30 (Greg Ferguson), 04/07/2010 05:16 PM

History

#1

Updated by jasim (Jasim A Basheer) over 9 years ago

=begin
Same issue in same environment. However reinstalling after a failed attempt causes the Seg Fault to go away.

C:~/Projects/r3> gem install haml
Successfully installed haml-2.2.24
1 gem installed
Installing ri documentation for haml-2.2.24...
/Users/jasim/.rvm/gems/ruby-1.8.7-p249/gems/rdoc-2.5.8/lib/rdoc/ri/store.rb:243: [BUG] Segmentation fault
ruby 1.8.7 (2010-01-10 patchlevel 249) [i686-darwin9.8.0]

Abort trap

C:~/Projects/r3> gem install haml
Successfully installed haml-2.2.24
1 gem installed
Installing ri documentation for haml-2.2.24...
Installing RDoc documentation for haml-2.2.24...

The environment is a vanilla ruby-1.8.7-p249 installed using RVM.
=end

#2

Updated by swindsor (Scott Windsor) over 9 years ago

=begin
I've also been getting a large number of seg faults after upgrading to 1.8.7 patchlevel 249. This is the new default for Ubuntu 10.04 and after I upgraded I've gotten repeated issues.

/usr/lib/ruby/gems/1.8/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:313: [BUG] Segmentation fault
ruby 1.8.7 (2010-01-10 patchlevel 249) [x86_64-linux]

I've also tried clearing out and re-install all of my gems, but that didn't help at all. It seems to be crashing regularly in different areas of active support. (Perhaps related to Marshall?). What further information can I provide to help this out?

=end

#3

Updated by tenderlovemaking (Aaron Patterson) over 9 years ago

=begin
On Thu, Jun 17, 2010 at 06:28:22AM +0900, Scott Windsor wrote:

Issue #3105 has been updated by Scott Windsor.

I've also been getting a large number of seg faults after upgrading to 1.8.7 patchlevel 249. This is the new default for Ubuntu 10.04 and after I upgraded I've gotten repeated issues.

/usr/lib/ruby/gems/1.8/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:313: [BUG] Segmentation fault
ruby 1.8.7 (2010-01-10 patchlevel 249) [x86_64-linux]

I've also tried clearing out and re-install all of my gems, but that didn't help at all. It seems to be crashing regularly in different areas of active support. (Perhaps related to Marshall?). What further information can I provide to help this out?

Hi Scott!

Have you tried reducing the gems you use and isolating the problem?

Can you possibly provide code to reproduce the problem?

Are you able to reproduce the problem during your tests?

If you can reproduce the problem while testing, can you try running them
from gdb and providing a stack trace?

--
Aaron Patterson
http://tenderlovemaking.com/

Attachment: (unnamed)
=end

#4

Updated by swindsor (Scott Windsor) over 9 years ago

=begin
I haven't been able to isolate this yet. I tried removing and re-installing all of my gems. Unfortunately, this is on a pretty big web application and is crashing randomly between requests. It's very likely an issue exposed with rails, or one of the gems I'm using, but it's a pretty long list so it's hard to tell right now.

I can get a core dump and load it into gdb, but it's not very helpful without debug symbols. Do you know how to install them?
=end

#5

Updated by tenderlovemaking (Aaron Patterson) over 9 years ago

=begin
On Thu, Jul 29, 2010 at 06:19:52AM +0900, Scott Windsor wrote:

Issue #3105 has been updated by Scott Windsor.

I haven't been able to isolate this yet. I tried removing and re-installing all of my gems. Unfortunately, this is on a pretty big web application and is crashing randomly between requests. It's very likely an issue exposed with rails, or one of the gems I'm using, but it's a pretty long list so it's hard to tell right now.

I can get a core dump and load it into gdb, but it's not very helpful without debug symbols. Do you know how to install them?

Unfortunately you'll have to recompile your ruby with the -g flag on
GCC.

What does the stack trace look like under gdb? Can you send us the
first 10 frames or so? Maybe they will help. If not, you'll definitely
need to recompile ruby. :-(

--
Aaron Patterson
http://tenderlovemaking.com/

Attachment: (unnamed)
=end

#6

Updated by jeremyevans0 (Jeremy Evans) 4 months ago

  • Status changed from Open to Closed
  • Description updated (diff)

Also available in: Atom PDF