Project

General

Profile

Bug #3084

ri shows the same description twice

Added by tomonacci (Tomo Kazahaya) over 10 years ago. Updated over 9 years ago.

Status:
Closed
Priority:
Normal
Target version:
ruby -v:
1.9.2dev (2010-04-03 trunk 27196) [i686-linux]
Backport:
[ruby-core:29231]

Description

=begin
For some classes/modules, ri shows the same description twice. e.g.:

$ ruby -v
ruby 1.9.2dev (2010-04-03 trunk 27196) [i686-linux]
$ ri RDoc
= RDoc

(from ruby core)


= RDoc - Ruby Documentation System

This package contains RDoc and ...
... document continues ...
merchantibility and fitness for a particular purpose.
= RDoc - Ruby Documentation System # I've already seen this!

This package contains RDoc and ...

The classes with this problem: Array, Hash, Time...
It seems like this only happens for the core classes, since I haven't found
any of the gem-installed classes suffering from this.
=end

#1

Updated by mame (Yusuke Endoh) over 10 years ago

  • Status changed from Open to Feedback
  • Assignee set to drbrain (Eric Hodel)

=begin
Hi,

Sorry for late response, but I cannot reproduce.

Rdoc has changed a lot since the begin of April.
Could you delete old installation and try trunk again?

Eric, if you know anything about this issue, please answer to OP.

--
Yusuke Endoh mame@tsg.ne.jp
=end

#2

Updated by tomonacci (Tomo Kazahaya) over 10 years ago

=begin
Hello,

It seems to be fixed for most of the classes.
Though Integer is still showing this symptom...
I removed files/directories under
/usr/local/bin/
/usr/local/share/ri/1.9.1/system
/.ext
~/.ri
~/.ri1.9.1
before 'make && sudo make install'.

% ruby -v
ruby 1.9.3dev (2010-05-13 trunk 27788) [i686-linux]
% ri -v
ri 2.5
% ri --no-pager Integer
Integer < Numeric


Includes:
(from ruby core)
Enumerable
Enumerable

(from ruby core)


Integer is the basis for the two concrete classes that hold whole
numbers, Bignum and Fixnum.
Integer is the basis for the two concrete classes that hold whole
numbers, Bignum and Fixnum.
...

=end

#3

Updated by mame (Yusuke Endoh) over 10 years ago

  • Status changed from Feedback to Assigned
  • Target version set to 1.9.2

=begin
Hi,

2010/5/14 Tomo Kazahaya redmine@ruby-lang.org:

It seems to be fixed for most of the classes.
Though Integer is still showing this symptom...

Thank you! Confirmed.

Eric, how about this patch?

diff --git a/lib/rdoc/class_module.rb b/lib/rdoc/class_module.rb
index 16b85d7..aeff33c 100644
--- a/lib/rdoc/class_module.rb
+++ b/lib/rdoc/class_module.rb
@@ -150,7 +150,7 @@ class RDoc::ClassModule < RDoc::Context
if comment then
document = parse @comment

  • comment.parts.concat document.parts
  •  comment.parts.replace document.parts
    
    @comment = comment
    

    end

--
Yusuke Endoh mame@tsg.ne.jp
=end

#4

Updated by drbrain (Eric Hodel) over 10 years ago

=begin
Your patch will disable a feature of RDoc which allows comments from multiple classes to be combined into one.

I like this patch better, may I commit it?

Index: lib/irb/ruby-token.rb
===================================================================
--- lib/irb/ruby-token.rb (revision 28016)
+++ lib/irb/ruby-token.rb (working copy)
@@ -17,11 +17,6 @@ module RubyToken
EXPR_DOT = :EXPR_DOT
EXPR_CLASS = :EXPR_CLASS

  • # for ruby 1.4X
  • if !defined?(Symbol)
  • Symbol = Integer
  • end - class Token def initialize(seek, line_no, char_no) @seek = seek

=end

#5

Updated by mame (Yusuke Endoh) over 10 years ago

=begin
Hi, Eric

Works for me. Please commit it!

And, Eric, please respond to #1085, #1800 and #2176 :-)

--
Yusuke Endoh mame@tsg.ne.jp
=end

#6

Updated by drbrain (Eric Hodel) over 10 years ago

  • Status changed from Assigned to Closed

=begin
Committed accidentally at r28158
=end

Also available in: Atom PDF