Project

General

Profile

Bug #1928

[BUG] rb_add_method: unsupported method type (8)

Added by dima4p (Dmitri Koulikov) about 11 years ago. Updated over 9 years ago.

Status:
Closed
Priority:
Normal
Target version:
ruby -v:
ruby 1.9.2dev (2009-07-18 trunk 24186) [i686-linux]
Backport:
[ruby-core:24865]

Description

=begin
/usr/local/lib/ruby/gems/1.9.1/gems/activesupport-2.3.3/lib/active_support/core_ext/try.rb:29: [BUG] rb_add_method: unsupported method type (8)

ruby 1.9.2dev (2009-07-18 trunk 24186) [i686-linux]

-- control frame ----------
c:0029 p:---- s:0081 b:0081 l:000080 d:000080 CFUNC :alias_method
c:0028 p:0044 s:0076 b:0076 l:000075 d:000075 CLASS /usr/local/lib/ruby/gems/1.9.1/gems/activesupport-2.3.3/lib/active_support/core_ext/try.rb:29
c:0027 p:0009 s:0074 b:0074 l:000073 d:000073 TOP /usr/local/lib/ruby/gems/1.9.1/gems/activesupport-2.3.3/lib/active_support/core_ext/try.rb:1
c:0026 p:---- s:0072 b:0072 l:000071 d:000071 FINISH
c:0025 p:---- s:0070 b:0070 l:000069 d:000069 CFUNC :require
c:0024 p:0040 s:0066 b:0066 l:000056 d:000065 BLOCK /usr/local/lib/ruby/gems/1.9.1/gems/activesupport-2.3.3/lib/active_support/core_ext.rb:3
c:0023 p:---- s:0062 b:0062 l:000061 d:000061 FINISH
c:0022 p:---- s:0060 b:0060 l:000059 d:000059 CFUNC :each
c:0021 p:0040 s:0057 b:0057 l:000056 d:000056 TOP /usr/local/lib/ruby/gems/1.9.1/gems/activesupport-2.3.3/lib/active_support/core_ext.rb:1
c:0020 p:---- s:0055 b:0055 l:000054 d:000054 FINISH
c:0019 p:---- s:0053 b:0053 l:000052 d:000052 CFUNC :require
c:0018 p:0033 s:0049 b:0049 l:000048 d:000048 TOP /usr/local/lib/ruby/gems/1.9.1/gems/activesupport-2.3.3/lib/active_support.rb:55
c:0017 p:---- s:0047 b:0047 l:000046 d:000046 FINISH
c:0016 p:---- s:0045 b:0045 l:000044 d:000044 CFUNC :require
c:0015 p:0013 s:0041 b:0041 l:000040 d:000040 TOP /usr/local/lib/ruby/gems/1.9.1/gems/activeresource-2.3.3/lib/active_resource.rb:25
c:0014 p:---- s:0038 b:0038 l:000037 d:000037 FINISH
c:0013 p:---- s:0036 b:0036 l:000035 d:000035 CFUNC :require
c:0012 p:0011 s:0032 b:0032 l:000031 d:000031 TOP /usr/local/lib/ruby/gems/1.9.1/gems/activeresource-2.3.3/lib/activeresource.rb:1
c:0011 p:---- s:0030 b:0030 l:000029 d:000029 FINISH
c:0010 p:---- s:0028 b:0028 l:000027 d:000027 CFUNC :require
c:0009 p:0011 s:0024 b:0024 l:000023 d:000023 TOP /home/dima/devel/os/adjax/platform/client/server.rb:3
c:0008 p:---- s:0022 b:0022 l:000021 d:000021 FINISH
c:0007 p:---- s:0020 b:0020 l:000019 d:000019 CFUNC :require
c:0006 p:0035 s:0016 b:0016 l:000015 d:000015 TOP /home/dima/devel/os/adjax/platform/client/client.rb:4
c:0005 p:---- s:0014 b:0014 l:000013 d:000013 FINISH
c:0004 p:---- s:0012 b:0012 l:000011 d:000011 CFUNC :require
c:0003 p:0043 s:0008 b:0008 l:00085c d:00067c EVAL init.rb:5
c:0002 p:---- s:0004 b:0004 l:000003 d:000003 FINISH
c:0001 p:0000 s:0002 b:0002 l:00085c d:00085c TOP


init.rb:5:in <main>'
init.rb:5:in
require'
/home/dima/devel/os/adjax/platform/client/client.rb:4:in <top (required)>'
/home/dima/devel/os/adjax/platform/client/client.rb:4:in
require'
/home/dima/devel/os/adjax/platform/client/server.rb:3:in <top (required)>'
/home/dima/devel/os/adjax/platform/client/server.rb:3:in
require'
/usr/local/lib/ruby/gems/1.9.1/gems/activeresource-2.3.3/lib/activeresource.rb:1:in <top (required)>'
/usr/local/lib/ruby/gems/1.9.1/gems/activeresource-2.3.3/lib/activeresource.rb:1:in
require'
/usr/local/lib/ruby/gems/1.9.1/gems/activeresource-2.3.3/lib/active_resource.rb:25:in <top (required)>'
/usr/local/lib/ruby/gems/1.9.1/gems/activeresource-2.3.3/lib/active_resource.rb:25:in
require'
/usr/local/lib/ruby/gems/1.9.1/gems/activesupport-2.3.3/lib/active_support.rb:55:in <top (required)>'
/usr/local/lib/ruby/gems/1.9.1/gems/activesupport-2.3.3/lib/active_support.rb:55:in
require'
/usr/local/lib/ruby/gems/1.9.1/gems/activesupport-2.3.3/lib/active_support/core_ext.rb:1:in <top (required)>'
/usr/local/lib/ruby/gems/1.9.1/gems/activesupport-2.3.3/lib/active_support/core_ext.rb:1:in
each'
/usr/local/lib/ruby/gems/1.9.1/gems/activesupport-2.3.3/lib/active_support/core_ext.rb:3:in block in <top (required)>'
/usr/local/lib/ruby/gems/1.9.1/gems/activesupport-2.3.3/lib/active_support/core_ext.rb:3:in
require'
/usr/local/lib/ruby/gems/1.9.1/gems/activesupport-2.3.3/lib/active_support/core_ext/try.rb:1:in <top (required)>'
/usr/local/lib/ruby/gems/1.9.1/gems/activesupport-2.3.3/lib/active_support/core_ext/try.rb:29:in
class:Object'
/usr/local/lib/ruby/gems/1.9.1/gems/activesupport-2.3.3/lib/active_support/core_ext/try.rb:29:in `alias_method'

-- C level backtrace information -------------------------------------------
/usr/local/bin/ruby(rb_vm_bugreport+0x9b) [0x81599ab]
/usr/local/bin/ruby [0x8192e6b]
/usr/local/bin/ruby(rb_bug+0x28) [0x8192ee8]
/usr/local/bin/ruby(rb_alias+0xfe) [0x814b92e]
/usr/local/bin/ruby [0x814bafb]
/usr/local/bin/ruby [0x8144897]
/usr/local/bin/ruby [0x8145677]
/usr/local/bin/ruby [0x814d868]
/usr/local/bin/ruby [0x814edd2]
/usr/local/bin/ruby [0x81564d7]
/usr/local/bin/ruby(rb_iseq_eval+0xfc) [0x815683c]
/usr/local/bin/ruby [0x81948b6]
/usr/local/bin/ruby(rb_require_safe+0x5ee) [0x8195bae]
/usr/local/bin/ruby [0x8145677]
/usr/local/bin/ruby [0x814d868]
/usr/local/bin/ruby [0x814edd2]
/usr/local/bin/ruby [0x81564d7]
/usr/local/bin/ruby [0x8156b62]
/usr/local/bin/ruby(rb_yield+0x33) [0x81573f3]
/usr/local/bin/ruby(rb_ary_each+0x3c) [0x816814c]
/usr/local/bin/ruby [0x8145677]
/usr/local/bin/ruby [0x814d868]
/usr/local/bin/ruby [0x814edd2]
/usr/local/bin/ruby [0x81564d7]
/usr/local/bin/ruby(rb_iseq_eval+0xfc) [0x815683c]
/usr/local/bin/ruby [0x81948b6]
/usr/local/bin/ruby(rb_require_safe+0x5ee) [0x8195bae]
/usr/local/bin/ruby [0x8145677]
/usr/local/bin/ruby [0x814d868]
/usr/local/bin/ruby [0x814edd2]
/usr/local/bin/ruby [0x81564d7]
/usr/local/bin/ruby(rb_iseq_eval+0xfc) [0x815683c]
/usr/local/bin/ruby [0x81948b6]
/usr/local/bin/ruby(rb_require_safe+0x5ee) [0x8195bae]
/usr/local/bin/ruby [0x8145677]
/usr/local/bin/ruby [0x814d868]
/usr/local/bin/ruby [0x814edd2]
/usr/local/bin/ruby [0x81564d7]
/usr/local/bin/ruby(rb_iseq_eval+0xfc) [0x815683c]
/usr/local/bin/ruby [0x81948b6]
/usr/local/bin/ruby(rb_require_safe+0x5ee) [0x8195bae]
/usr/local/bin/ruby [0x8145677]
/usr/local/bin/ruby [0x814d868]
/usr/local/bin/ruby [0x814edd2]
/usr/local/bin/ruby [0x81564d7]
/usr/local/bin/ruby(rb_iseq_eval+0xfc) [0x815683c]
/usr/local/bin/ruby [0x81948b6]
/usr/local/bin/ruby(rb_require_safe+0x5ee) [0x8195bae]
/usr/local/bin/ruby [0x8145677]
/usr/local/bin/ruby [0x814d868]
/usr/local/bin/ruby [0x814edd2]
/usr/local/bin/ruby [0x81564d7]
/usr/local/bin/ruby(rb_iseq_eval+0xfc) [0x815683c]
/usr/local/bin/ruby [0x81948b6]
/usr/local/bin/ruby(rb_require_safe+0x5ee) [0x8195bae]
/usr/local/bin/ruby [0x8145677]
/usr/local/bin/ruby [0x814d868]
/usr/local/bin/ruby [0x814edd2]
/usr/local/bin/ruby [0x81564d7]
/usr/local/bin/ruby(rb_iseq_eval+0xfc) [0x815683c]
/usr/local/bin/ruby [0x81948b6]
/usr/local/bin/ruby(rb_require_safe+0x5ee) [0x8195bae]
/usr/local/bin/ruby [0x8145677]
/usr/local/bin/ruby [0x814d868]
/usr/local/bin/ruby [0x814edd2]
/usr/local/bin/ruby [0x81564d7]
/usr/local/bin/ruby(rb_iseq_eval_main+0x198) [0x8156718]
/usr/local/bin/ruby(ruby_exec_node+0xa4) [0x805a934]
/usr/local/bin/ruby(ruby_run_node+0x4d) [0x805c4cd]
/usr/local/bin/ruby(main+0x52) [0x8059d92]
/lib/libc.so.6(__libc_start_main+0xe0) [0xb7e4e390]
/usr/local/bin/ruby [0x8059cd1]

[NOTE]
You may have encountered a bug in the Ruby interpreter or extension libraries.
Bug reports are welcome.
For details: http://www.ruby-lang.org/bugreport.html

./run: line 11: 31675 Aborted /usr/local/bin/ruby init.rb
=end


Related issues

Is duplicate of Ruby master - Bug #1788: ある種のメソッドをalias_methodしようとすると落ちるClosed07/19/2009Actions
#1

Updated by ko1 (Koichi Sasada) about 11 years ago

=begin
Could you show me a script around /usr/local/lib/ruby/gems/1.9.1/gems/activesupport-2.3.3/lib/active_support/core_ext/try.rb:29 ? Or URL of this script is fine.
=end

#2

Updated by mark-moseley (Mark Moseley) about 11 years ago

=begin
I got this error earlier today when I ran "rails foo" on ruby-1.9.2-preview1.

It worked, through, when I tried it a few hours ago on the trunk 24504, so I think this has been fixed.
=end

#3

Updated by nobu (Nobuyoshi Nakada) about 11 years ago

  • Category set to core
  • Status changed from Open to Closed

=begin
same as #1788.

=end

Also available in: Atom PDF