Project

General

Profile

Bug #15502

Expired certificates in Ruby 2.6.0 test suite

Added by vo.x (Vit Ondruch) over 1 year ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
ruby -v:
ruby 2.6.0p0 (2018-12-25 revision 66547) [x86_64-linux]
[ruby-core:90874]

Description

There are test failures in Ruby 2.6 such as:

  1) Failure:
FTPTest#test_tls_with_ca_file [/builddir/build/BUILD/ruby-2.6.0/test/net/ftp/test_ftp.rb:1719]:
Exception raised:
<#<OpenSSL::SSL::SSLError: SSL_connect returned=1 errno=0 state=error: certificate verify failed (certificate has expired)>>.

This was fixed in trunk by r66685 and r66686. It would be nice if these could be backported.

It would be even better if the certificates won't expire at all or were regularly updated to prevent this silly issue (test suite of freshly released ruby fails) in the future.

Updated by vo.x (Vit Ondruch) over 1 year ago

  • Status changed from Open to Closed

Closing to trigger the backport request.

Updated by naruse (Yui NARUSE) over 1 year ago

  • Backport changed from 2.4: UNKNOWN, 2.5: UNKNOWN, 2.6: REQUIRED to 2.4: UNKNOWN, 2.5: UNKNOWN, 2.6: DONE

ruby_2_6 r66728 merged revision(s) 66685,66686.

Updated by vo.x (Vit Ondruch) over 1 year ago

  • Backport changed from 2.4: UNKNOWN, 2.5: UNKNOWN, 2.6: DONE to 2.4: UNKNOWN, 2.5: DONE, 2.6: DONE

It was backported into 2.5 branch by r66689.

Also available in: Atom PDF