Project

General

Profile

Bug #14455

Dir.glob with FNM_CASEFOLD gives ArgumentError: invalid byte sequence in UTF-8

Added by Gondolin (Damien Robert) about 3 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
[ruby-core:85447]

Description

With ruby 2.5.0p0, in a folder that contains a file encoded in latin-1, I get the following error:

Dir.glob('*a', File::FNM_CASEFOLD)
ArgumentError: invalid byte sequence in UTF-8

Note that Dir.glob('*', File::FNM_CASEFOLD), Dir.glob('a*', File::FNM_CASEFOLD) and Dir.glob('a*') work.


Related issues

Is duplicate of Ruby master - Bug #14456: Dir.glob with FNM_CASEFOLD gives ArgumentError: invalid byte sequence in UTF-8OpenActions
#1

Updated by duerst (Martin Dürst) about 3 years ago

  • Is duplicate of Bug #14456: Dir.glob with FNM_CASEFOLD gives ArgumentError: invalid byte sequence in UTF-8 added
#2

Updated by duerst (Martin Dürst) about 3 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF