Project

General

Profile

Bug #14402

Crash and coredump (Stack consistency error) on ruby 2.5.0

Added by jrochkind (jonathan rochkind) over 1 year ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
ruby -v:
ruby 2.5.0p0 (2017-12-25 revision 61468) [x86_64-darwin16]
[ruby-core:85119]

Description

This reproduction script seems to make no sense, because it's extracted from an actual program where I encountered this bug, and trimmed down to be the minimal I can get to reproduce.

Parts of the script that seem irrelevant (like the if check that should never be true), if removed, remove the reproduction. This is why I'm glad I'm not a C programmer!

This executes without core dump on ruby 2.4.3p205 (2017-12-14 revision 61247) [x86_64-darwin16] -- runs fine, does not reproduce error, on 2.4.

I believe on ruby 2.5 it also reproduces on travis (which is where I originally encountered the problem), so I don't believe it is unique to the MacOS ruby build I am reporting here.

Console output at: https://gist.github.com/jrochkind/0e6ed450414f4577bdb886961e4d61ba

Crash report log file from ~/Library/Logs/DiagnosticReports/ruby_2018-01-25-113636_170220-C02T63QEFVH4.crash at:
https://gist.github.com/jrochkind/6cbd60845cf36352491fb6d058ea2910


Related issues

Is duplicate of Ruby trunk - Bug #14273: Stack Consistency Error from return in loopClosedActions

History

Updated by jrochkind (jonathan rochkind) over 1 year ago

Sorry accidentally double-reported, the issue tracker gave me an error on first submit and I thought it hadn't been submitted. Close in favor of https://bugs.ruby-lang.org/issues/14403

#2

Updated by nobu (Nobuyoshi Nakada) over 1 year ago

  • Is duplicate of Bug #14273: Stack Consistency Error from return in loop added
#3

Updated by nobu (Nobuyoshi Nakada) over 1 year ago

  • Status changed from Open to Closed

Also available in: Atom PDF