Project

General

Profile

Bug #13760

Another iseq_set_sequence: adjust bug 1 < 2

Added by fumfel (Kamil Frankowicz) over 2 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
ruby -v:
ruby 2.5.0dev (2017-07-11 trunk 59311) [x86_64-linux]
[ruby-core:82117]

Description

After some fuzz testing I found a crashing test case.

To reproduce: miniruby ruby_iseq_set_sequence

Context:

ruby_iseq_set_sequence:3: [BUG] iseq_set_sequence: adjust bug 1 < 2
ruby 2.5.0dev (2017-07-11 trunk 59311) [x86_64-linux]

-- Control frame information -----------------------------------------------
c:0001 p:0000 s:0003 E:000030 (none) [FINISH]


-- C level backtrace information -------------------------------------------
XYZ/ruby/miniruby(rb_vm_bugreport+0x2b7) [0x55ff0c4ff3c7] vm_dump.c:671
XYZ/ruby/miniruby(rb_report_bug_valist+0x269) [0x55ff0c1bfa49] error.c:588
XYZ/ruby/miniruby(compile_bug+0xb9) [0x55ff0c144279] compile.c:354
XYZ/ruby/miniruby(iseq_setup+0x4266) [0x55ff0c1484e6] compile.c:1661
XYZ/ruby/miniruby(rb_iseq_compile_node+0x257) [0x55ff0c141687] compile.c:662
XYZ/ruby/miniruby(rb_iseq_new_with_opt+0xbf) [0x55ff0c25c90f] iseq.c:505
XYZ/ruby/miniruby(rb_iseq_new_main+0x7b) [0x55ff0c25cdcb] iseq.c:475
XYZ/ruby/miniruby(ruby_process_options+0x1e90) [0x55ff0c3b5c20] ruby.c:1727
XYZ/ruby/miniruby(ruby_options+0x1b6) [0x55ff0c1cfb16] eval.c:103
XYZ/ruby/miniruby(main+0x81) [0x55ff0c0c5981] ./main.c:42

-- Other runtime information -----------------------------------------------

* Loaded script: ruby_iseq_set_sequence

* Loaded features:

    0 enumerator.so
    1 thread.rb
    2 rational.so
    3 complex.so

* Process memory map:

55ff0c0a0000-55ff0c5d3000 r-xp 00000000 fc:00 530955                     XYZ/ruby/miniruby
55ff0c7d3000-55ff0c7d9000 r--p 00533000 fc:00 530955                     XYZ/ruby/miniruby
55ff0c7d9000-55ff0c7da000 rw-p 00539000 fc:00 530955                     XYZ/ruby/miniruby
55ff0c7da000-55ff0c7fb000 rw-p 00000000 00:00 0 
55ff0cbbb000-55ff0ccf5000 rw-p 00000000 00:00 0                          [heap]
7fbf71fc0000-7fbf72189000 r--s 00000000 fc:00 415265                     /lib/x86_64-linux-gnu/libc-2.23.so
7fbf72189000-7fbf72df1000 r--s 00000000 fc:00 530955                     XYZ/ruby/miniruby
7fbf72df1000-7fbf72e07000 r-xp 00000000 fc:00 392981                     /lib/x86_64-linux-gnu/libgcc_s.so.1
7fbf72e07000-7fbf73006000 ---p 00016000 fc:00 392981                     /lib/x86_64-linux-gnu/libgcc_s.so.1
7fbf73006000-7fbf73007000 rw-p 00015000 fc:00 392981                     /lib/x86_64-linux-gnu/libgcc_s.so.1
7fbf73007000-7fbf732df000 r--p 00000000 fc:00 15064                      /usr/lib/locale/locale-archive
7fbf732df000-7fbf7349f000 r-xp 00000000 fc:00 415265                     /lib/x86_64-linux-gnu/libc-2.23.so
7fbf7349f000-7fbf7369f000 ---p 001c0000 fc:00 415265                     /lib/x86_64-linux-gnu/libc-2.23.so
7fbf7369f000-7fbf736a3000 r--p 001c0000 fc:00 415265                     /lib/x86_64-linux-gnu/libc-2.23.so
7fbf736a3000-7fbf736a5000 rw-p 001c4000 fc:00 415265                     /lib/x86_64-linux-gnu/libc-2.23.so
7fbf736a5000-7fbf736a9000 rw-p 00000000 00:00 0 
7fbf736a9000-7fbf737b1000 r-xp 00000000 fc:00 415260                     /lib/x86_64-linux-gnu/libm-2.23.so
7fbf737b1000-7fbf739b0000 ---p 00108000 fc:00 415260                     /lib/x86_64-linux-gnu/libm-2.23.so
7fbf739b0000-7fbf739b1000 r--p 00107000 fc:00 415260                     /lib/x86_64-linux-gnu/libm-2.23.so
7fbf739b1000-7fbf739b2000 rw-p 00108000 fc:00 415260                     /lib/x86_64-linux-gnu/libm-2.23.so
7fbf739b2000-7fbf739bb000 r-xp 00000000 fc:00 415247                     /lib/x86_64-linux-gnu/libcrypt-2.23.so
7fbf739bb000-7fbf73bba000 ---p 00009000 fc:00 415247                     /lib/x86_64-linux-gnu/libcrypt-2.23.so
7fbf73bba000-7fbf73bbb000 r--p 00008000 fc:00 415247                     /lib/x86_64-linux-gnu/libcrypt-2.23.so
7fbf73bbb000-7fbf73bbc000 rw-p 00009000 fc:00 415247                     /lib/x86_64-linux-gnu/libcrypt-2.23.so
7fbf73bbc000-7fbf73bea000 rw-p 00000000 00:00 0 
7fbf73bea000-7fbf73bed000 r-xp 00000000 fc:00 415254                     /lib/x86_64-linux-gnu/libdl-2.23.so
7fbf73bed000-7fbf73dec000 ---p 00003000 fc:00 415254                     /lib/x86_64-linux-gnu/libdl-2.23.so
7fbf73dec000-7fbf73ded000 r--p 00002000 fc:00 415254                     /lib/x86_64-linux-gnu/libdl-2.23.so
7fbf73ded000-7fbf73dee000 rw-p 00003000 fc:00 415254                     /lib/x86_64-linux-gnu/libdl-2.23.so
7fbf73dee000-7fbf73e06000 r-xp 00000000 fc:00 415248                     /lib/x86_64-linux-gnu/libpthread-2.23.so
7fbf73e06000-7fbf74005000 ---p 00018000 fc:00 415248                     /lib/x86_64-linux-gnu/libpthread-2.23.so
7fbf74005000-7fbf74006000 r--p 00017000 fc:00 415248                     /lib/x86_64-linux-gnu/libpthread-2.23.so
7fbf74006000-7fbf74007000 rw-p 00018000 fc:00 415248                     /lib/x86_64-linux-gnu/libpthread-2.23.so
7fbf74007000-7fbf7400b000 rw-p 00000000 00:00 0 
7fbf7400b000-7fbf74031000 r-xp 00000000 fc:00 415243                     /lib/x86_64-linux-gnu/ld-2.23.so
7fbf74122000-7fbf74227000 rw-p 00000000 00:00 0 
7fbf7422a000-7fbf7422b000 ---p 00000000 00:00 0 
7fbf7422b000-7fbf74230000 rw-p 00000000 00:00 0 
7fbf74230000-7fbf74231000 r--p 00025000 fc:00 415243                     /lib/x86_64-linux-gnu/ld-2.23.so
7fbf74231000-7fbf74232000 rw-p 00026000 fc:00 415243                     /lib/x86_64-linux-gnu/ld-2.23.so
7fbf74232000-7fbf74233000 rw-p 00000000 00:00 0 
7ffcf723a000-7ffcf7a39000 rw-p 00000000 00:00 0                          [stack]
7ffcf7b1e000-7ffcf7b20000 r--p 00000000 00:00 0                          [vvar]
7ffcf7b20000-7ffcf7b22000 r-xp 00000000 00:00 0                          [vdso]
ffffffffff600000-ffffffffff601000 r-xp 00000000 00:00 0                  [vsyscall]


[NOTE]
You may have encountered a bug in the Ruby interpreter or extension libraries.
Bug reports are welcome.
For details: http://www.ruby-lang.org/bugreport.html

Aborted (core dumped)

Files

ruby_iseq_set_sequence (33 Bytes) ruby_iseq_set_sequence fumfel (Kamil Frankowicz), 07/20/2017 04:25 PM

Related issues

Is duplicate of Ruby master - Bug #13755: Null pointer dereference in hash_table_index()ClosedActions

History

Updated by shyouhei (Shyouhei Urabe) over 2 years ago

  • Status changed from Open to Feedback

Can't reproduce on ruby 2.5.0dev (2017-07-21 trunk 59374) [x86_64-darwin15]. Maybe fixed already. Would you mind trying a recent trunk?

Updated by nobu (Nobuyoshi Nakada) over 2 years ago

Seems a duplicate of #13755.

#3

Updated by nobu (Nobuyoshi Nakada) over 2 years ago

  • Is duplicate of Bug #13755: Null pointer dereference in hash_table_index() added
#4

Updated by nobu (Nobuyoshi Nakada) over 2 years ago

  • Status changed from Feedback to Closed
#5

Updated by usa (Usaku NAKAMURA) over 2 years ago

  • Backport changed from 2.2: UNKNOWN, 2.3: UNKNOWN, 2.4: UNKNOWN to 2.2: DONTNEED, 2.3: DONTNEED, 2.4: DONE

Also available in: Atom PDF