Project

General

Profile

Bug #11985

SignalException: SIGABRT when rake test

Added by wensen (Vincent Ting) over 3 years ago. Updated about 1 month ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
ruby -v:
ruby 2.3.0p0 (2015-12-25 revision 53290) [x86_64-darwin15]
[ruby-core:72839]

Files

ruby_2016-01-13-160348_vincent-mbpr.crash (18 KB) ruby_2016-01-13-160348_vincent-mbpr.crash DiagnosticReports wensen (Vincent Ting), 01/13/2016 08:04 AM
crashed.png (701 KB) crashed.png wensen (Vincent Ting), 01/14/2016 01:49 PM

History

Updated by nobu (Nobuyoshi Nakada) over 3 years ago

How can I reproduce it?

Updated by nobu (Nobuyoshi Nakada) over 3 years ago

  • Status changed from Open to Feedback

Updated by wensen (Vincent Ting) over 3 years ago

Nobuyoshi Nakada wrote:

How can I reproduce it?

Sorry, I'm trying to minify my code to reproduce it, but still not work out yet. I'll paste it here as soon as I finish it.

Updated by wensen (Vincent Ting) over 3 years ago

I met with failures when i tried to simplify my code, SignalException will always be disappeared when i try to delete some codes. So i have to use the whole project as an example.

  1. Clone the unfinished project https://github.com/waiiio/resta
  2. Delete some method name to_s in https://github.com/waiiio/resta/blob/master/lib/resta/resource.rb#L253
  3. Run bundle install then rake test and it will show [BUG] vm_call_cfunc - cfp consistency error
  4. It may caused by https://github.com/waiiio/resta/blob/master/test/resource_test.rb#L71 ,It seems that it should get stuck in an infinite loop because of https://github.com/waiiio/resta/blob/master/lib/resta/resource.rb#L357

!crashed.png!

Updated by wensen (Vincent Ting) over 3 years ago

  • Subject changed from SignalException: SIGABRT to SignalException: SIGABRT when rake test
#6

Updated by jeremyevans0 (Jeremy Evans) about 1 month ago

  • Status changed from Feedback to Closed

Also available in: Atom PDF