Project

General

Profile

Bug #11838

Please backport r52883, r52884, r53046, r53198

Added by duerst (Martin Dürst) almost 5 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Normal
Target version:
-
[ruby-core:72228]

Description

These are straightforward bug fixes. Please backport, thanks!


Related issues

Related to Ruby master - Bug #11843: enc/windows_1250.c syntax error with fcc on Solaris -- C++(C99)-style comments should not be usedClosedActions

Updated by duerst (Martin Dürst) almost 5 years ago

  • Subject changed from Please backport r52883, r52884, r53046 to Please backport r52883, r52884, r53046, r53198

Updated by nagachika (Tomoyuki Chikanaga) over 4 years ago

  • Status changed from Open to Assigned

Thank you for your notice.

I'll close this ticket because it's already done on trunk and stable branch maintainers (usa san and I) watch closed ticket with REQUIRED Backport field.

Updated by nagachika (Tomoyuki Chikanaga) over 4 years ago

  • Status changed from Assigned to Closed

Updated by duerst (Martin Dürst) over 4 years ago

On 2016/01/21 10:48, nagachika00@gmail.com wrote:

Issue #11838 has been updated by Tomoyuki Chikanaga.

Status changed from Assigned to Closed


Bug #11838: Please backport r52883, r52884, r53046, r53198
https://bugs.ruby-lang.org/issues/11838#change-56221

  • Author: Martin Dürst
  • Status: Closed
  • Priority: Normal
  • Assignee: Tomoyuki Chikanaga
  • ruby -v:

* Backport: 2.0.0: REQUIRED, 2.1: REQUIRED, 2.2: REQUIRED

These are straightforward bug fixes. Please backport, thanks!

trunk ですでに直っているバグについて、最初から Closed にした方がいいで
しょうか。

それと、このバグを backport していただくにはさらに何か必要でしょうか。

よろしくお願いします。 Martin.

Updated by usa (Usaku NAKAMURA) over 4 years ago

Martin Dürst wrote:

trunk ですでに直っているバグについて、最初から Closed にした方がいいで
しょうか。

Yes.
でも、わかっていたら、でいいです。

それと、このバグを backport していただくにはさらに何か必要でしょうか。

いいえ、これで十分です。
ありがとうございます。

Updated by nagachika (Tomoyuki Chikanaga) over 4 years ago

  • Backport changed from 2.0.0: REQUIRED, 2.1: REQUIRED, 2.2: REQUIRED to 2.0.0: REQUIRED, 2.1: REQUIRED, 2.2: DONE

Backported into ruby_2_2 branch at r53896.

Updated by nagachika (Tomoyuki Chikanaga) over 4 years ago

usa san,
Please note that r53198 requires #11843 (r53202) too.

#8

Updated by usa (Usaku NAKAMURA) over 4 years ago

  • Related to Bug #11843: enc/windows_1250.c syntax error with fcc on Solaris -- C++(C99)-style comments should not be used added

Updated by usa (Usaku NAKAMURA) over 4 years ago

  • Backport changed from 2.0.0: REQUIRED, 2.1: REQUIRED, 2.2: DONE to 2.0.0: REQUIRED, 2.1: DONE, 2.2: DONE

ruby_2_1 r54261 merged revision(s) 52883,52884,53046,53198.

Also available in: Atom PDF